#evergreen: Evergreen development meeting, 8 November 2017

Meeting started by gmcharlt at 15:00:48 US/Eastern (full logs).

Meeting summary

    1. Agenda is https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2017-11-08 (gmcharlt, 15:00:54)

  1. Introductions (gmcharlt, 15:01:04)
    1. gmcharlt = Galen Charlton, Equinox (gmcharlt, 15:01:20)
    2. bshum = Ben Shum, evergreener (bshum, 15:01:58)
    3. rhamby = Rogan Hamby, Equinox (rhamby, 15:02:03)
    4. DPearl = Dan Pearl, C/W MARS (DPearl, 15:02:14)
    5. JBoyer = Jason Boyer, IN State Lib (JBoyer, 15:02:49)
    6. Dyrcona = Jason Stephenson, C/W MARS (Dyrcona, 15:03:20)
    7. phasefx = Jason Etheridge, Equinox (phasefx, 15:04:01)
    8. berick Bill Erickson, KCLS (berick, 15:04:02)
    9. remingtron = Remington Steed, Hekman Library (Calvin College) (remingtron, 15:04:20)
    10. Bmagic = Blake GH, MOBIUS (Bmagic, 15:04:53)

  2. Action items from previous meeting (gmcharlt, 15:04:55)
    1. dbwells = Dan Wells, Hekman Library (Calvin College) (dbwells, 15:04:55)
    2. ACTION: gmcharlt will open and work on bugs for documentation changes for better ejabberd configuration during installation of OpenSRF (gmcharlt, 15:05:10)
    3. csharp = Chris Sharp, GPLS, but you knew that (csharp, 15:05:14)
    4. cesardv = Cesar Velez, EOLI (cesardv, 15:05:23)
    5. abneiman is Andrea Neiman, EOLI (abneiman, 15:05:28)
    6. miker = Mike Rylander, EOLI (miker, 15:05:42)
    7. There is now a Chrome Web Store account onto which we can upload the Hatch extension (gmcharlt, 15:05:58)
    8. ACTION: berick will upload Hatch to the Chrome Store in the next couple weeks or so (gmcharlt, 15:07:12)
    9. maryj has created an icon and promotional image for the Hatch extension (gmcharlt, 15:07:37)
    10. dbwells has sent out a call for additional buildmasters (gmcharlt, 15:09:21)

  3. OpenSRF release (gmcharlt, 15:11:14)
    1. Another release expected in the next couple weeks, given additional bundling/chunking bugs (gmcharlt, 15:11:50)

  4. Evergreen release (gmcharlt, 15:12:59)
    1. http://libmail.georgialibraries.org/pipermail/open-ils-general/2017-November/014381.html (gmcharlt, 15:14:41)

  5. Hack-a-way update (gmcharlt, 15:15:22)
    1. As of the moment, patches for ~15 bugs have been pushed since the hack-a-way started (gmcharlt, 15:15:46)
    2. We discussed plans for starting project of upgrading Angular; berick has offerred to do some initial prototyping (gmcharlt, 15:16:26)
    3. Test instances of GitLab and Phabricator are being set up (gmcharlt, 15:16:58)
    4. Using pofilter to test our current PO translations; finding useful tidbits to eventually be shared back with the translator teams and greater group. (bshum, 15:17:44)
    5. Some updates are being tracked on the agenda page: https://wiki.evergreen-ils.org/doku.php?id=hack-a-way-2017-agenda (gmcharlt, 15:17:45)
    6. There's also a shared Google doc: https://docs.google.com/document/d/19EctprR1cybery-zbaNBntRmyASMYcRwt4-6S1-YNts/edit (gmcharlt, 15:18:10)
    7. We perfomed a successful denial of service attack on the omelet line this morning (gmcharlt, 15:20:22)


Meeting ended at 15:23:42 US/Eastern (full logs).

Action items

  1. gmcharlt will open and work on bugs for documentation changes for better ejabberd configuration during installation of OpenSRF
  2. berick will upload Hatch to the Chrome Store in the next couple weeks or so


Action items, by person

  1. berick
    1. berick will upload Hatch to the Chrome Store in the next couple weeks or so
  2. gmcharlt
    1. gmcharlt will open and work on bugs for documentation changes for better ejabberd configuration during installation of OpenSRF


People present (lines said)

  1. gmcharlt (40)
  2. kmlussier (9)
  3. pinesol_green (9)
  4. Dyrcona (8)
  5. csharp (7)
  6. JBoyer (5)
  7. berick (4)
  8. dbwells (4)
  9. cesardv (3)
  10. miker (3)
  11. bshum (3)
  12. rhamby (3)
  13. Bmagic (2)
  14. remingtron (2)
  15. DPearl (1)
  16. phasefx (1)
  17. abneiman (1)


Generated by MeetBot 0.1.4.