#evergreen: 2021-11-09 - Developer Meeting, Agenda Available at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2021-11-09

Meeting started by JBoyer at 15:02:00 US/Eastern (full logs).

Meeting summary

  1. Introductions (JBoyer, 15:02:06)
    1. JBoyer = Jason Boyer, EOLI (JBoyer, 15:02:17)
    2. terranm = Terran McCanna, PINES (terranm, 15:02:26)
    3. mmorgan = Michele Morgan, NOBLE (mmorgan, 15:02:34)
    4. abneiman = Andrea Buntz Neiman, Equinox (abneiman, 15:02:37)
    5. gmcharlt = Galen Charlton, EOLI (gmcharlt, 15:02:51)
    6. csharp = Chris Sharp, GPLS (csharp_, 15:02:56)
    7. alynn26 = Lynn Floyd, Evergreen Indiana (alynn26, 15:03:05)
    8. berick = Bill Erickson, KCLS (berick, 15:03:17)
    9. sandbergja = Jane Sandberg, LBCC (sandbergja, 15:03:35)

  2. Action Items from Last Meeting (JBoyer, 15:04:05)
    1. shulabear will test out the staff client in Microsoft Edge (JBoyer, 15:04:12)
    2. Dyrcona = Jason Stephenson, CW MARS (Dyrcona, 15:05:12)

  3. OpenSRF Release Updates (JBoyer, 15:05:32)
  4. Evergreen Release Updates (JBoyer, 15:07:57)
  5. Launchpad Snapshot as of noon-ish Eastern (JBoyer, 15:10:22)
    1. Pull Requests - 78 (JBoyer, 15:10:33)
    2. Signed-off Bugs - 39 (JBoyer, 15:10:38)

  6. Launchpad Changes Since Last Meeting (JBoyer, 15:10:54)
    1. Bugs Added - 49 (JBoyer, 15:10:58)
    2. Pull Requests Added - 15 (JBoyer, 15:11:02)
    3. Sign-offs Added - 3 (JBoyer, 15:11:06)
    4. Fixes Committed - 9 (JBoyer, 15:11:11)
    5. shulabear = Shula Link, GPLS/GCHR (shulabear, 15:11:27)

  7. New Business (JBoyer, 15:16:06)
    1. Updating Evergreen for Newer PostgreSQL Versions ( lp 1937294 ) (JBoyer, 15:16:23)
    2. Dyrcona's notes on PostgreSQL testing: https://drive.google.com/drive/folders/1sRZ8P1RHCOcZx42DxUehvOpoNkJJnfqn (Dyrcona, 15:26:53)
    3. array_accum Aggregate and PostgreSQL 14 ( lp 1947595 ) (JBoyer, 15:32:49)
    4. ACTION: JBoyer will test out the branch in lp 1947595 (JBoyer, 15:38:22)
    5. Hackaway followup: Automating point release notes (abneiman) (JBoyer, 15:38:49)
    6. Launchpad bug 1948674 in Evergreen "Improve release building automation" [Undecided,New] https://launchpad.net/bugs/1948674 (csharp_, 15:49:14)

  8. Announcements (JBoyer, 15:50:51)
    1. next meeting is December 14th, 2021 (JBoyer, 15:50:56)


Meeting ended at 15:51:07 US/Eastern (full logs).

Action items

  1. JBoyer will test out the branch in lp 1947595


Action items, by person

  1. JBoyer
    1. JBoyer will test out the branch in lp 1947595


People present (lines said)

  1. JBoyer (77)
  2. Dyrcona (21)
  3. csharp_ (17)
  4. abneiman (9)
  5. pinesol (9)
  6. terranm (6)
  7. mmorgan (5)
  8. gmcharlt (4)
  9. shulabear (3)
  10. sandbergja (3)
  11. berick (2)
  12. alynn26 (2)


Generated by MeetBot 0.1.4.