#evergreen: 2022-05-10 - Developer Meeting

Meeting started by JBoyer at 15:00:19 US/Eastern (full logs).

Meeting summary

    1. Agenda at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2022-05-10 (JBoyer, 15:00:27)

  1. Introductions (JBoyer, 15:00:33)
    1. terranm = Terran McCanna, PINES (terranm, 15:00:43)
    2. JBoyer = Jason Boyer, EOLI (JBoyer, 15:00:51)
    3. shulabear = Shula Link, GCHRL in PINES (shulabear, 15:00:56)
    4. abneiman = Andrea Buntz Neiman, Equinox (abneiman, 15:00:59)
    5. mmorgan = Michele Morgan, NOBLE (mmorgan, 15:01:12)
    6. collum = Garry Collum, KCPL (collum, 15:01:22)
    7. Bmagic = Blake GH, MOBIUS (Bmagic, 15:01:48)
    8. Dyrcona = Jason Stephenson, CWMARS (Dyrcona, 15:01:49)

  2. Action Items from Last Meeting (JBoyer, 15:03:12)
    1. ACTION: miker will may have looked into bug 1955079 (JBoyer, 15:03:33)

  3. Evergreen Release Updates (JBoyer, 15:03:54)
    1. From miker earlier today: "we cut 3.9.0 on April 27 and then I was promptly out of the office for travel and not-work until basically today. I did get the tarball and friends up on the downloads site last week, but we had a suspected broken-build issue, which thankfully turned out to be a false alarm, but delayed the release announcement. so, I still owe the world an email to say "come and get it," but you can, indeed, come and (JBoyer, 15:04:01)
    2. ACTION: miker will ring the dinnerbell re: Evergreen 3.9.0 on the lists (JBoyer, 15:04:10)
    3. phasefx = Jason Etheridge, EOLI (phasefx, 15:14:28)
    4. ACTION: sandbergja will prep auto-drafted release notes for abneiman and mmorgan to review for 3.7.3 and 3.8.1 (JBoyer, 15:15:28)
    5. ACTION: Dyrcona will try to collect data on release processes across some open source projects for consideration (JBoyer, 15:23:22)

  4. Launchpad Status (JBoyer, 15:24:02)
    1. Snapshot (JBoyer, 15:24:03)
    2. Open Bugs - 2711 (JBoyer, 15:24:10)
    3. Pullrequests - 84 (JBoyer, 15:24:11)
    4. Signedoff - 32 (JBoyer, 15:24:17)
    5. Updates Since Last Meeting (JBoyer, 15:24:17)
    6. Bugs Added - 31 (JBoyer, 15:24:21)
    7. Pullrequest tag Added - 15 (JBoyer, 15:24:27)
    8. Signedoff tag Added - 3 (JBoyer, 15:24:37)
    9. Fix Committed - 8 (JBoyer, 15:24:39)

  5. New Business (JBoyer, 15:25:01)
    1. timeline for deprecating TPAC and the traditional staff catalogue (JBoyer, 15:25:07)
    2. VOTE: Voted on "Shall the TPAC and Traditional Staff Catalog(ue) be officially deprecated when 3.10 is released?" Results are, yes: 9 (JBoyer, 15:43:21)
    3. Live tester update (JBoyer, 15:45:42)
    4. http://testing.evergreen-ils.org/~live/archive/2022-04/2022-04-25_16:00:04/test.49.html (phasefx, 15:46:36)
    5. https://git.evergreen-ils.org/?p=working/random.git;a=shortlog;h=refs/heads/collab/phasefx/eg_live_tests (phasefx, 15:48:29)

  6. Announcements (JBoyer, 16:01:22)
    1. Next Meeting is June 17th at 3pm Eastern / 12 Pacific during the Conference Hackfest (JBoyer, 16:01:26)


Meeting ended at 16:01:31 US/Eastern (full logs).

Action items

  1. miker will may have looked into bug 1955079
  2. miker will ring the dinnerbell re: Evergreen 3.9.0 on the lists
  3. sandbergja will prep auto-drafted release notes for abneiman and mmorgan to review for 3.7.3 and 3.8.1
  4. Dyrcona will try to collect data on release processes across some open source projects for consideration


Action items, by person

  1. abneiman
    1. sandbergja will prep auto-drafted release notes for abneiman and mmorgan to review for 3.7.3 and 3.8.1
  2. Dyrcona
    1. Dyrcona will try to collect data on release processes across some open source projects for consideration
  3. mmorgan
    1. sandbergja will prep auto-drafted release notes for abneiman and mmorgan to review for 3.7.3 and 3.8.1
  4. sandbergja
    1. sandbergja will prep auto-drafted release notes for abneiman and mmorgan to review for 3.7.3 and 3.8.1
  5. UNASSIGNED
    1. miker will may have looked into bug 1955079
    2. miker will ring the dinnerbell re: Evergreen 3.9.0 on the lists


People present (lines said)

  1. JBoyer (82)
  2. Dyrcona (25)
  3. mmorgan (15)
  4. terranm (15)
  5. sandbergja (13)
  6. phasefx (12)
  7. abneiman (10)
  8. jeffdavis (9)
  9. pinesol (9)
  10. shulabear (8)
  11. collum (3)
  12. Bmagic (1)


Generated by MeetBot 0.1.4.