#evergreen: 2022-09-13 - Developer Meeting

Meeting started by JBoyer at 15:00:35 US/Eastern (full logs).

Meeting summary

    1. Agenda at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2022-09-13 (JBoyer, 15:00:39)

  1. Introductions (JBoyer, 15:00:46)
    1. Dyrcona = Jason Stephenson, CWMARS (Dyrcona, 15:00:59)
    2. gmcharlt = Galen Charlton, Equinox (gmcharlt, 15:00:59)
    3. JBoyer = Jason Boyer, EOLI (JBoyer, 15:01:16)
    4. jeffdavis = Jeff Davis, BC Libraries Cooperative (Sitka) (jeffdavis, 15:01:22)
    5. sandbergja = Jane Sandberg, Evergreen enthusiast (sandbergja, 15:01:30)
    6. shulabear = Shula Link, GCHR in PINES (shulabear, 15:01:33)
    7. mmorgan = Michele Morgan, NOBLE (mmorgan, 15:01:34)
    8. abneiman = Andrea Buntz Neiman, Equinox (abneiman, 15:01:41)
    9. rhamby = Rogan Hamby, Equinox (rhamby, 15:01:53)
    10. collum = Garry Collum, KCPL (collum, 15:02:15)
    11. terranm = Terran McCanna, PINES (terranm, 15:02:21)
    12. stephengwills Maine Balsam Libraries (stephengwills, 15:02:40)

  2. Action Items from Last Meeting (JBoyer, 15:03:08)
    1. Dyrcona will take a look at LP 1979357 (JBoyer, 15:03:13)
    2. ACTION: JBoyer will take a look at LP 1979357 (JBoyer, 15:04:39)
    3. JBoyer will propose LP users to trim from Drivers / Wranglers / etc. lists. (JBoyer, 15:05:01)
    4. miker = Mike Rylander, EOLI, belated (miker, 15:05:26)
    5. Bmagic = Blake GH, MOBIUS (Bmagic, 15:05:47)
    6. A merge freeze will be in effect EOB 9/14 so releases can be cut this week (JBoyer, 15:12:14)

  3. Launchpad Status (JBoyer, 15:14:32)
    1. Snapshot (JBoyer, 15:14:35)
    2. Open Bugs - 2844 (JBoyer, 15:14:39)
    3. Pullrequests - 95 (JBoyer, 15:14:42)
    4. Signedoff - 62 (JBoyer, 15:14:44)
    5. Updates Since Last Meeting (JBoyer, 15:14:49)
    6. Bugs Added - 52 (JBoyer, 15:14:53)
    7. Pullrequest tag Added - 28 (JBoyer, 15:14:58)
    8. Signedoff tag Added - 7 (JBoyer, 15:15:02)
    9. Fix Committed - 6 (JBoyer, 15:15:05)

  4. New Business (JBoyer, 15:15:27)
  5. 3.10 release manager / team / etc. Volunteer, Voluntell, or Voluntold; your choice! (JBoyer, 15:15:35)
  6. Should there be a standalone offline client? (see e.g. LP#1943486) (JBoyer, 15:41:56)
    1. https://bugs.launchpad.net/evergreen/+bug/1943486 (terranm, 15:43:01)
    2. berick's offline proof of concept: https://github.com/berick/eg-offline-jfx (Dyrcona, 15:52:44)

  7. Migrating away from the deprecated Angular linter (see LP#1959048) (JBoyer, 15:58:19)
    1. ACTION: sandbergja will followup with berick about timing re: merging the new linter (JBoyer, 16:07:29)

  8. Announcements (JBoyer, 16:09:19)
    1. Next Meeting is October 11, 2022 (JBoyer, 16:09:22)


Meeting ended at 16:09:25 US/Eastern (full logs).

Action items

  1. JBoyer will take a look at LP 1979357
  2. sandbergja will followup with berick about timing re: merging the new linter


Action items, by person

  1. JBoyer
    1. JBoyer will take a look at LP 1979357
  2. sandbergja
    1. sandbergja will followup with berick about timing re: merging the new linter


People present (lines said)

  1. JBoyer (82)
  2. gmcharlt (39)
  3. terranm (20)
  4. sandbergja (18)
  5. mmorgan (16)
  6. Dyrcona (16)
  7. Bmagic (15)
  8. shulabear (11)
  9. pinesol (8)
  10. miker (5)
  11. jeffdavis (4)
  12. collum (4)
  13. abneiman (4)
  14. mrussell (3)
  15. stephengwills (1)
  16. rhamby (1)


Generated by MeetBot 0.1.4.