#evergreen: 2022-12-13 Developer Meeting

Meeting started by Dyrcona at 15:02:08 US/Eastern (full logs).

Meeting summary

  1. Introductions (Dyrcona, 15:02:16)
    1. phasefx = Jason Etheridge, EOLI (phasefx, 15:02:31)
    2. rhamby = Rogan Hamby, EOLI (rhamby, 15:02:40)
    3. mmorgan = Michele Morgan, NOBLE (mmorgan, 15:02:45)
    4. Dyrcona = Jason Stephenson CW MARS (Dyrcona, 15:02:46)
    5. sleary = Stephanie Leary, EOLI (sleary, 15:03:09)
    6. shulabear = Shula Link, GCHRL in PINES (shulabear, 15:03:12)
    7. collum = Garry Collum, KCPL (collum, 15:03:51)
    8. stompro = Josh Stompro, LARL (Stompro, 15:03:58)

  2. Action Items from Last Meeting (Dyrcona, 15:04:37)
    1. jeffdavis will gather more specific examples of recurring QA problems to present for discussion at the next dev meeting (Dyrcona, 15:04:49)
    2. ACTION: jeffdavis will gather more specific examples of recurring QA problems to present for discussion at the next dev meeting (Dyrcona, 15:06:54)

  3. OpenSRF Release Updates (Dyrcona, 15:07:12)
    1. gmcharlt isn't able to be here today but said that the OpenSRF release is still on and should drop next week (Dyrcona, 15:07:30)

  4. Evergreen Release Updates (Dyrcona, 15:09:08)
    1. Contribution of LibraryIQ export code. Github? Contrib repo? It will be similar to collectionHQ, which is inside of a contrib repo. (Bmagic) (Dyrcona, 15:09:29)
    2. ACTION: Bmagic to email the development list about a way to share common Evergreen tools with the community. (Dyrcona, 15:23:20)
    3. Enhanced Concerto dataset. LP 1901932 (Bmagic) (Dyrcona, 15:23:42)
    4. ACTION: Dyrcona to review Lp 1901932 (Dyrcona, 15:31:42)

  5. Documentation Updates (Dyrcona, 15:35:00)
    1. Where's our technical documentation? For a newbie: how to use $e (editor), what is $ctx, etc.I know there's docs/TechRef but I don't know if it is included in the online antora docs or if it's been updated any time recently. (Dyrcona, 15:35:20)
    2. New Devs wiki page: https://wiki.evergreen-ils.org/doku.php?id=newdevs:start (Dyrcona, 15:47:40)

  6. Launchpad Status (Dyrcona, 15:50:22)
    1. Snapshot (Dyrcona, 15:50:22)
    2. Open Bugs - 2847 (Dyrcona, 15:50:22)
    3. Pullrequests - 91 (Dyrcona, 15:50:22)
    4. Signedoff - 38 (Dyrcona, 15:50:22)
    5. Updates Since Last Meeting (Dyrcona, 15:50:22)
    6. Bugs Added - 53 (Dyrcona, 15:50:22)
    7. Pullrequest tag Added - 25 (Dyrcona, 15:50:23)
    8. Signedoff tag Added - 4 (Dyrcona, 15:50:23)
    9. Fix Committed - 8 (Dyrcona, 15:50:24)

  7. New Busines (Dyrcona, 15:51:13)
    1. Recommended PostgreSQL version now that Pg 10 is out of support. (Dyrcona, 15:51:47)
    2. Open bugs related to newer PostgreSQL versions: Lp 1999274 and Lp 1997098. (Dyrcona, 15:54:47)

  8. Announcements (Dyrcona, 15:55:49)
    1. Next Meeting is January 10th, 2023 (Dyrcona, 15:59:32)


Meeting ended at 15:59:37 US/Eastern (full logs).

Action items

  1. jeffdavis will gather more specific examples of recurring QA problems to present for discussion at the next dev meeting
  2. Bmagic to email the development list about a way to share common Evergreen tools with the community.
  3. Dyrcona to review Lp 1901932


Action items, by person

  1. Bmagic
    1. Bmagic to email the development list about a way to share common Evergreen tools with the community.
  2. Dyrcona
    1. Dyrcona to review Lp 1901932
  3. jeffdavis
    1. jeffdavis will gather more specific examples of recurring QA problems to present for discussion at the next dev meeting


People present (lines said)

  1. Dyrcona (77)
  2. Bmagic (31)
  3. mmorgan (8)
  4. pinesol (7)
  5. shulabear (6)
  6. jeffdavis (6)
  7. rhamby (2)
  8. scottangel (2)
  9. sleary (1)
  10. phasefx (1)
  11. collum (1)
  12. Stompro (1)


Generated by MeetBot 0.1.4.