#evergreen: 2023-05-09 - Developer Meeting

Meeting started by JBoyer at 15:01:09 US/Eastern (full logs).

Meeting summary

    1. Agenda at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2023-05-09 (JBoyer, 15:01:14)

  1. Introductions (JBoyer, 15:01:19)
    1. Dyrcona = Jason Stephenson, CW MARS (Dyrcona, 15:01:29)
    2. JBoyer = Jason Boyer, EOLI (JBoyer, 15:01:40)
    3. phasefx = Jason Etheridge, EOLI (phasefx, 15:01:43)
    4. dluch = Debbie Luchenbill, MOBIUS (dluch, 15:01:50)
    5. Stompro = Josh Stompro, LARL (Stompro, 15:01:55)
    6. mmorgan = Michele Morgan, NOBLE (mmorgan, 15:01:56)
    7. berick Bill Erickson, KCLS (here for 1st half of mtg) (berick, 15:02:05)
    8. sleary = Stephanie Leary, EOLI (sleary, 15:02:10)
    9. collum = Garry Collum, KCPL (collum, 15:02:11)
    10. terranm = Terran McCanna, PINES (terranm, 15:02:27)
    11. tlittle = Tiffany Little, PINES (tlittle, 15:02:33)
    12. shulabear = Shula Link, PINES/GCHRL (shulabear, 15:02:46)
    13. abneiman = Andrea Buntz Neiman, EOLI (abneiman, 15:03:34)

  2. Action Items from Last Meeting (JBoyer, 15:05:45)
    1. None. (JBoyer, 15:05:49)

  3. OpenSRF Release Updates (JBoyer, 15:06:01)
    1. OpenSRF 3.2.3 has been released to fix some memory leaks and most importantly allow building on recent Debian / Ubuntu releases. (JBoyer, 15:06:05)

  4. Evergreen Release Updates (JBoyer, 15:08:03)
    1. Feedback Fest going on now, progress looks good (JBoyer, 15:08:30)
    2. Evergreen 3.11 Beta 1 coming Monday (JBoyer, 15:08:31)
    3. Evergreen 3.10.1a tarball released today (2022-05-09) to add a missing upgrade script. (Dyrcona, 15:09:17)
    4. Bmagic = Blake GH, MOBIUS (Bmagic, 15:13:20)

  5. Documentation Updates (JBoyer, 15:13:47)
    1. Documentation hackfest: Lots of new folks in the morning! Got them started with our reorg spreadsheet, a live demo from Andrea, talked about 3.11 some, and other general docs conversations (JBoyer, 15:14:00)
    2. No May meeting last week, next meeting on June 1 (JBoyer, 15:14:07)
    3. https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meetings:20230601-agenda (JBoyer, 15:14:10)

  6. Launchpad Status (JBoyer, 15:14:55)
    1. Snapshot (JBoyer, 15:14:59)
    2. Open Bugs - 2963 (JBoyer, 15:15:02)
    3. Pullrequests - 74 (JBoyer, 15:15:06)
    4. Signedoff - 16 (JBoyer, 15:15:09)
    5. Updates Since Last Meeting (JBoyer, 15:15:14)
    6. Bugs Added - 80 (JBoyer, 15:15:17)
    7. Pullrequest tag Added - 42 (JBoyer, 15:15:20)
    8. Signedoff tag Added - 27 (JBoyer, 15:15:25)
    9. Fix Committed - 60 (JBoyer, 15:15:29)

  7. New Business (JBoyer, 15:16:29)
  8. Git server move and branch renaming from master to main (JBoyer, 15:16:33)
    1. SSH access to git.evergreen-ils.org repositories will be disabled on June 1, 2023 at 13:00 UTC (9:00 AM EDT). (Dyrcona, 15:17:35)
    2. Git repositories will be moved to a new host and "master" branches renamed to "main." (Dyrcona, 15:17:50)
    3. rfrasur = Ruth Frasur, Evergreen Indiana / ECDI (rfrasur, 15:19:15)
    4. ACTION: Dyrcona will communicate what our git users need to do as a result of these changes via email and blog posts. (Dyrcona, 15:19:49)

  9. The business of running these things (JBoyer, 15:28:17)
  10. Announcements (JBoyer, 15:36:14)
    1. Next Meeting is June 13, 2023 (JBoyer, 15:36:18)


Meeting ended at 15:36:24 US/Eastern (full logs).

Action items

  1. Dyrcona will communicate what our git users need to do as a result of these changes via email and blog posts.


Action items, by person

  1. Dyrcona
    1. Dyrcona will communicate what our git users need to do as a result of these changes via email and blog posts.


People present (lines said)

  1. JBoyer (75)
  2. Dyrcona (22)
  3. Bmagic (11)
  4. mmorgan (8)
  5. dluch (7)
  6. terranm (6)
  7. shulabear (5)
  8. tlittle (4)
  9. jeff (4)
  10. collum (4)
  11. pinesol (3)
  12. rfrasur (1)
  13. sleary (1)
  14. abneiman (1)
  15. berick (1)
  16. phasefx (1)
  17. Stompro (1)


Generated by MeetBot 0.1.4.