#evergreen: 2023-08-08 - Developer Meeting

Meeting started by Bmagic at 15:00:33 US/Eastern (full logs).

Meeting summary

    1. Agenda at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2023-08-08 (Bmagic, 15:00:42)

  1. Introductions (Bmagic, 15:00:48)
    1. Bmagic = Blake GH, MOBIUS (Bmagic, 15:00:54)
    2. sleary = Stephanie Leary, Equinox (sleary, 15:01:17)
    3. jeff = Jeff Godin, Traverse Area District Library (TADL) (jeff, 15:01:19)
    4. eeevil = Mike Rylander, EOLI (someone snagged my nick ... grrrrr) (eeevil, 15:01:22)
    5. berick Bill Erickson, KCLS (berick, 15:01:24)
    6. mmorgan = Michele Morgan, NOBLE (mmorgan, 15:01:28)
    7. tlittle = Tiffany Little, PINES (tlittle, 15:01:32)
    8. abneiman = Andrea Buntz Neiman, Equinox (abneiman, 15:01:33)
    9. Stompro = Josh Stompro, LARL/NWRL (Stompro, 15:01:38)
    10. sandbergja = Jane Sandberg, Princeton University Library (sandbergja, 15:01:58)
    11. collum = Garry Collum, KCPL (collum, 15:02:14)
    12. smayo = Steven Mayo, PINES (smayo, 15:02:24)

  2. Action Items from Last Meeting (Bmagic, 15:03:03)
    1. mmorgan will explore moving LP stats to community site and automating same (Bmagic, 15:03:07)
    2. Dyrcona = Jason Stephenson, CW MARS. (Dyrcona, 15:03:19)
    3. https://docs.google.com/spreadsheets/d/1igd02X0VjIcJrGdmcEQ34bAha8b3IHYprHkdZhcOkkE/edit?usp=sharing (Bmagic, 15:04:03)
    4. sharpsie = Chris Sharp, GPLS (sharpsie, 15:04:15)

  3. OpenSRF (Bmagic, 15:05:12)
  4. Evergreen (Bmagic, 15:06:27)
    1. EG security releases on Jul 24: https://evergreen-ils.org/evergreen-security-releases-3-9-4-3-10-3-and-3-11-1/ (abneiman, 15:07:08)

  5. Documentation (Bmagic, 15:08:41)
    1. DIG Meeting rescheduled to Thursday, August 10 (Bmagic, 15:08:50)

  6. Documentation - Accessibility guide is now copied into the wiki. Let sleary know what you'd like to see added. (Bmagic, 15:09:17)
    1. https://wiki.evergreen-ils.org/doku.php?id=accessibility:start (Bmagic, 15:09:23)

  7. Launchpad Status (as of noon Eastern) (Bmagic, 15:11:27)
    1. Open Bugs - 2971 (Bmagic, 15:11:46)
    2. Pullrequests - 89 (Bmagic, 15:11:46)
    3. Signedoff - 14 (Bmagic, 15:11:46)

  8. Launchpad Updates Since Last Meeting (Bmagic, 15:12:20)
    1. Bugs Added - 39 (Bmagic, 15:12:29)
    2. Pullrequest tag Added - 10 (Bmagic, 15:12:29)
    3. Signedoff tag Added - 4 (Bmagic, 15:12:29)
    4. Fix Committed - 2 (Bmagic, 15:12:29)

  9. New Business (Bmagic, 15:12:55)
    1. Throw together a draft of some of this dev-facing documentation? (Bmagic, 15:13:10)
    2. https://wiki.evergreen-ils.org/doku.php?id=newdevs:tutorials-wanted (Bmagic, 15:13:29)
    3. ACTION: berick will make tutorial: "How grid cell templates work" (Bmagic, 15:16:37)
    4. ACTION: jeff will make tutorial: "Add missing field to print template" (Bmagic, 15:18:06)
    5. ACTION: sandbergja will write tutorial: "Do a database call (Galen’s cat counter)" (Bmagic, 15:20:48)
    6. ACTION: jeff will write tutorial "Retrieve a user's setting and do something based on its value" (Bmagic, 15:23:52)
    7. ACTION: berick will write enticing tutorial "Guide to the various store services" (Bmagic, 15:25:35)

  10. Are we ready to think about Angular 16? (Bmagic, 15:28:22)
    1. Fall release planning / release team (Bmagic, 15:33:50)
    2. ACTION: Bmagic will send a call for volunteers to the dev list (Bmagic, 15:39:57)

  11. Announcements (Bmagic, 15:40:18)
    1. Next Meeting is Tuesday, September 12th (Bmagic, 15:40:24)
    2. Bug Squashing Week is August 21-25 (Bmagic, 15:40:38)
    3. https://wiki.evergreen-ils.org/doku.php?id=dev:bug_squashing (Bmagic, 15:40:43)
    4. Enhanced concerto improvements (date carry) Lp 2023690 (Bmagic, 15:42:29)


Meeting ended at 15:43:10 US/Eastern (full logs).

Action items

  1. berick will make tutorial: "How grid cell templates work"
  2. jeff will make tutorial: "Add missing field to print template"
  3. sandbergja will write tutorial: "Do a database call (Galen’s cat counter)"
  4. jeff will write tutorial "Retrieve a user's setting and do something based on its value"
  5. berick will write enticing tutorial "Guide to the various store services"
  6. Bmagic will send a call for volunteers to the dev list


Action items, by person

  1. berick
    1. berick will make tutorial: "How grid cell templates work"
    2. berick will write enticing tutorial "Guide to the various store services"
  2. Bmagic
    1. Bmagic will send a call for volunteers to the dev list
  3. jeff
    1. jeff will make tutorial: "Add missing field to print template"
    2. jeff will write tutorial "Retrieve a user's setting and do something based on its value"
  4. sandbergja
    1. sandbergja will write tutorial: "Do a database call (Galen’s cat counter)"


People present (lines said)

  1. Bmagic (81)
  2. sleary (17)
  3. berick (14)
  4. abneiman (12)
  5. mmorgan (11)
  6. sandbergja (10)
  7. jeff (9)
  8. pinesol (7)
  9. sharpsie (4)
  10. tlittle (3)
  11. eeevil (2)
  12. smayo (1)
  13. collum (1)
  14. JBoyer (1)
  15. jvwoolf (1)
  16. Stompro (1)
  17. Dyrcona (1)


Generated by MeetBot 0.1.4.