#evergreen: 2023-09-12 - Developer Meeting

Meeting started by Bmagic at 15:00:01 US/Eastern (full logs).

Meeting summary

    1. Agenda at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2023-09-12 (Bmagic, 15:00:13)

  1. Introductions (Bmagic, 15:00:20)
    1. Dyrcona = Jason Stephenson, CW MARS (Dyrcona, 15:00:22)
    2. Bmagic = Blake GH, MOBIUS (Bmagic, 15:00:24)
    3. berick Bill Erickson, KCLS (berick, 15:00:40)
    4. shulabear = Shula Link, GCHR in PINES (shulabear, 15:00:44)
    5. jeffdavis = Jeff Davis, BC Libraries Cooperative (Sitka) (jeffdavis, 15:00:52)
    6. abneiman = Andrea Buntz Neiman, EOLI (abneiman, 15:00:54)
    7. collum = Garry Collum, KCPL (collum, 15:00:55)
    8. eeevil = Mike Rylander, EOLI (eeevil, 15:00:57)
    9. sleary = Stephanie Leary, EOLI (sleary, 15:01:02)
    10. jeff = Jeff Godin, Traverse Area District Library (TADL) (jeff, 15:01:14)
    11. JBoyer = Jason Boyer, EOLI (JBoyer, 15:01:17)

  2. Action Items from Last Meeting (Bmagic, 15:01:48)
    1. Stompro = Josh Stompro LARL/NWRL (Stompro, 15:01:51)
    2. mmorgan will explore moving LP stats to community site and automating same (Bmagic, 15:01:59)
    3. berick will make tutorial: "How grid cell templates work" (Bmagic, 15:03:29)
    4. terranm = Terran McCanna, PINES (terranm, 15:04:20)
    5. briank = Brian Kennedy, BCLC (Sitka) (briank, 15:06:10)
    6. ACTION: jeff will make tutorial: "Add missing field to print template" (Bmagic, 15:06:49)
    7. ACTION: jeff will write tutorial "Retrieve a user's setting and do something based on its value" (Bmagic, 15:06:56)
    8. ACTION: mmorgan will explore moving LP stats to community site and automating same (Bmagic, 15:07:05)
    9. sandbergja will write tutorial: "Do a database call (Galen’s cat counter)" (Bmagic, 15:08:46)
    10. Bmagic will send a call for volunteers to the dev list (Bmagic, 15:09:44)
    11. ACTION: sandbergja will write tutorial: "Do a database call (Galen’s cat counter)" (Bmagic, 15:10:35)

  3. Evergreen - Fall release planning / release team (Bmagic, 15:11:09)
    1. Evergreen 3.12 Release Team meeting Friday at 2pm ET - ping abneiman for more info (Bmagic, 15:12:15)
    2. rfrasur = Ruth Frasur, EGIN / ECDI (rfrasur, 15:13:12)

  4. Documentation (Bmagic, 15:18:06)
  5. Launchpad Status (as of noon Eastern) (Bmagic, 15:22:57)
    1. Open Bugs - 3023 (Bmagic, 15:23:03)
    2. Pullrequests - 91 (Bmagic, 15:23:09)
    3. Signedoff - 19 (Bmagic, 15:23:12)

  6. Launchpad Status since last meeting (Bmagic, 15:23:32)
    1. Bugs Added - 69 (Bmagic, 15:23:35)
    2. Pullrequest tag Added - 43 (Bmagic, 15:23:37)
    3. Signedoff tag Added - 34 (Bmagic, 15:23:40)
    4. Fix Committed - 32 (Bmagic, 15:23:42)

  7. New Business - LP#2032835: Should we merge OpenSRF into Evergreen? (Bmagic, 15:24:27)
    1. kmlussier is Kathy Lussier, NOBLE (kmlussier, 15:28:12)
    2. ACTION: berick will post something to the email list about merging OpenSRF into Evergreen (Bmagic, 15:31:41)
    3. https://bugs.launchpad.net/opensrf/+bug/2032835 (Bmagic, 15:31:56)
    4. https://bugs.launchpad.net/opensrf/+bug/2032835 (Bmagic, 15:32:51)

  8. LP#1999823: concurrent changes to EG and OpenSRF required; testing requested (Bmagic, 15:33:07)
    1. https://bugs.launchpad.net/opensrf/+bug/1999823 (Bmagic, 15:33:20)

  9. Announcements (Bmagic, 15:44:31)
    1. Congratulations to new core committer, Josh Stompro! (Bmagic, 15:44:36)
    2. Next meeting is Tuesday, October 10th (Bmagic, 15:45:58)


Meeting ended at 15:46:14 US/Eastern (full logs).

Action items

  1. jeff will make tutorial: "Add missing field to print template"
  2. jeff will write tutorial "Retrieve a user's setting and do something based on its value"
  3. mmorgan will explore moving LP stats to community site and automating same
  4. sandbergja will write tutorial: "Do a database call (Galen’s cat counter)"
  5. berick will post something to the email list about merging OpenSRF into Evergreen


Action items, by person

  1. berick
    1. berick will post something to the email list about merging OpenSRF into Evergreen
  2. jeff
    1. jeff will make tutorial: "Add missing field to print template"
    2. jeff will write tutorial "Retrieve a user's setting and do something based on its value"
  3. mmorgan
    1. mmorgan will explore moving LP stats to community site and automating same
  4. sandbergja
    1. sandbergja will write tutorial: "Do a database call (Galen’s cat counter)"


People present (lines said)

  1. Bmagic (79)
  2. Dyrcona (23)
  3. abneiman (14)
  4. berick (14)
  5. jeffdavis (13)
  6. JBoyer (11)
  7. terranm (10)
  8. rfrasur (9)
  9. sleary (8)
  10. mmorgan (7)
  11. pinesol (6)
  12. sandbergja (5)
  13. shulabear (4)
  14. kmlussier (3)
  15. collum (3)
  16. Stompro (3)
  17. jeff (2)
  18. briank (1)
  19. eeevil (1)


Generated by MeetBot 0.1.4.