#evergreen: 2023-10-10 - Developer Meeting

Meeting started by Bmagic at 15:02:10 US/Eastern (full logs).

Meeting summary

    1. Agenda at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2023-10-10 (Bmagic, 15:02:20)

  1. Introductions (Bmagic, 15:02:29)
    1. Bmagic = Blake GH, MOBIUS (Bmagic, 15:02:38)
    2. terranm = Terran McCanna, PINES (terranm, 15:02:45)
    3. collum = Garry Collum, KCPL (collum, 15:02:47)
    4. jeff = Jeff Godin, Traverse Area District Library (TADL) (jeff, 15:02:48)
    5. dluch = Debbie Luchenbill, MOBIUS (dluch, 15:02:48)
    6. mmorgan = Michele Morgan, NOBLE (mmorgan, 15:03:02)
    7. shulabear = Shula Link, GCHRL (shulabear, 15:03:05)
    8. Stompro = Josh Stompro, LARL and NWRL (Stompro, 15:03:19)
    9. berick Bill Erickson, KCLS (berick, 15:03:32)
    10. abneiman = Andrea Buntz Neiman, Equinox (abneiman, 15:03:49)
    11. eeevil = Mike Rylander, EOLI (eeevil, 15:03:56)
    12. Dyrcona = Jason Stephenson, CW MARS (Dyrcona, 15:04:02)
    13. sleary = Stephanie Leary, EOLI (sleary, 15:04:02)

  2. Action Items from Last Meeting (Bmagic, 15:04:24)
    1. jeff will make tutorial: "Add missing field to print template" (Bmagic, 15:04:33)
    2. jeff will write tutorial "Retrieve a user's setting and do something based on its value" (Bmagic, 15:04:49)
    3. mmorgan will explore moving LP stats to community site and automating same (Bmagic, 15:05:29)
    4. sandbergja will write tutorial: "Do a database call (Galen’s cat counter)" (Bmagic, 15:06:02)
    5. berick will post something to the email list about merging OpenSRF into Evergreen (Bmagic, 15:07:53)
    6. ACTION: jeff will make tutorial: "Add missing field to print template" (Bmagic, 15:09:27)
    7. ACTION: jeff will write tutorial "Retrieve a user's setting and do something based on its value" (Bmagic, 15:09:32)
    8. ACTION: mmorgan will explore moving LP stats to community site and automating same (Bmagic, 15:09:37)
    9. ACTION: sandbergja will write tutorial: "Do a database call (Galen’s cat counter)" (Bmagic, 15:09:41)

  3. OpenSRF (Bmagic, 15:10:03)
  4. Evergreen - 3.12 Release Schedule & Roadmap (Bmagic, 15:11:20)
    1. https://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap#release_schedule (Bmagic, 15:11:30)
    2. https://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap:3.12 (Bmagic, 15:11:54)
    3. https://bugs.launchpad.net/evergreen/+bugs?field.searchtext=&orderby=-importance&field.status%3Alist=NEW&field.status%3Alist=CONFIRMED&field.status%3Alist=TRIAGED&field.status%3Alist=INPROGRESS&field.status%3Alist=INCOMPLETE_WITH_RESPONSE&field.status%3Alist=INCOMPLETE_WITHOUT_RESPONSE&assignee_option=any&field.assignee=&field.bug_reporter=&field.bug_commenter=&field.subscriber=&field.structural_subscriber=&field.tag=pullrequest+ (Bmagic, 15:12:58)
    4. https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2023-10-10 (dluch, 15:13:31)

  5. Evergreen - Jane is hosting weekly review meetings on Mondays at 2pm ET (Bmagic, 15:14:35)
  6. Documentation (Bmagic, 15:15:56)
    1. DIG Meeting this Thursday, October 12, at 11am/12pm/1pm/2pm (Bmagic, 15:16:09)
    2. https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meetings:20231012-agenda (Bmagic, 15:16:16)

  7. Launchpad Status (as of noon Eastern) (Bmagic, 15:18:00)
    1. Open Bugs - 3072 (Bmagic, 15:18:09)
    2. Pullrequests - 94 (Bmagic, 15:18:09)
    3. Signedoff - 21 (Bmagic, 15:18:09)

  8. Launchpad Status since last meeting (Bmagic, 15:18:14)
    1. Bugs Added - 55 (Bmagic, 15:18:19)
    2. Pullrequest tag Added - 19 (Bmagic, 15:18:19)
    3. Signedoff tag Added - 8 (Bmagic, 15:18:19)
    4. Fix Committed - 12 (Bmagic, 15:18:19)

  9. New Business - Should we interfile nightwatch tests into the typical eg2/src/app directory (bug 2036831)? - Jane (Bmagic, 15:18:44)
    1. https://bugs.launchpad.net/evergreen/+bug/2036831 (Bmagic, 15:18:57)
    2. VOTE: Voted on "Shall we move the tests to related places in the Evergreen codebase?" Results are, yes: 6 (Bmagic, 15:27:59)

  10. Announcements (Bmagic, 15:29:15)
    1. ACTION: sandbergja will go over the Nightwatch test reorg with folks at the Monday at 2pm ET meeting or another time as available (Bmagic, 15:36:29)
    2. Next Meeting is Tuesday, November 14th (Bmagic, 15:37:38)
    3. Hack-a-way is coming up! (Bmagic, 15:39:40)
    4. https://wiki.evergreen-ils.org/doku.php?id=hack-a-way:hack-a-way-2023 (Bmagic, 15:39:45)


Meeting ended at 15:42:21 US/Eastern (full logs).

Action items

  1. jeff will make tutorial: "Add missing field to print template"
  2. jeff will write tutorial "Retrieve a user's setting and do something based on its value"
  3. mmorgan will explore moving LP stats to community site and automating same
  4. sandbergja will write tutorial: "Do a database call (Galen’s cat counter)"
  5. sandbergja will go over the Nightwatch test reorg with folks at the Monday at 2pm ET meeting or another time as available


Action items, by person

  1. jeff
    1. jeff will make tutorial: "Add missing field to print template"
    2. jeff will write tutorial "Retrieve a user's setting and do something based on its value"
  2. mmorgan
    1. mmorgan will explore moving LP stats to community site and automating same
  3. sandbergja
    1. sandbergja will write tutorial: "Do a database call (Galen’s cat counter)"
    2. sandbergja will go over the Nightwatch test reorg with folks at the Monday at 2pm ET meeting or another time as available


People present (lines said)

  1. Bmagic (83)
  2. sandbergja (18)
  3. dluch (14)
  4. pinesol (13)
  5. shulabear (12)
  6. abneiman (9)
  7. berick (9)
  8. mmorgan (9)
  9. sleary (6)
  10. Dyrcona (6)
  11. terranm (6)
  12. collum (3)
  13. jeff (2)
  14. eeevil (1)
  15. Stompro (1)


Generated by MeetBot 0.1.4.