#evergreen: 2023-11-14 - Developer Meeting

Meeting started by Bmagic at 15:00:01 US/Eastern (full logs).

Meeting summary

    1. Agenda at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2023-11-14 (Bmagic, 15:00:08)

  1. Introductions (Bmagic, 15:00:14)
    1. Bmagic = Blake GH, MOBIUS (Bmagic, 15:00:18)
    2. Dyrcona = Jason Stephenson, C/W MARS (Dyrcona, 15:00:26)
    3. shulabear = Shula Link, GCHRL in PINES (shulabear, 15:00:37)
    4. mmorgan = Michele Morgan, NOBLE (mmorgan, 15:00:39)
    5. csharp_ = Chris Sharp, GPLS (csharp_, 15:00:39)
    6. terranm = Terran McCanna, PINES (terranm, 15:00:41)
    7. Stompro = Josh Stompro, LARL (Stompro, 15:00:42)
    8. jeff = Jeff Godin, Traverse Area District Library (TADL) (jeff, 15:00:48)
    9. collum = Garry Collum, KCPL (collum, 15:00:49)
    10. sleary = Stephanie Leary, Equinox (sleary, 15:00:52)
    11. smayo = Steven Mayo, PINES (smayo, 15:00:55)

  2. Action Items from Last Meeting (Bmagic, 15:01:28)
    1. JBoyer = Jason Boyer, EOLI (JBoyer, 15:01:31)
    2. jeff will write tutorial "Retrieve a user's setting and do something based on its value" (Bmagic, 15:01:39)
    3. jeff will make tutorial: "Add missing field to print template" (Bmagic, 15:02:00)
    4. ACTION: jeff will make tutorial: "Add missing field to print template" (Bmagic, 15:03:39)
    5. ACTION: jeff will write tutorial "Retrieve a user's setting and do something based on its value"#action jeff will write tutorial "Retrieve a user's setting and do something based on its value" (Bmagic, 15:03:44)
    6. eeevil = Mike Rylander, eoli (eeevil, 15:03:59)
    7. sandbergja = Jane Sandberg, PUL/independent (sandbergja, 15:04:03)
    8. mmorgan will explore moving LP stats to community site and automating same (Bmagic, 15:04:08)
    9. phasefx = Jason Etheridge, EOLI (phasefx, 15:04:15)
    10. ACTION: mmorgan will explore moving LP stats to community site and automating same (Bmagic, 15:04:35)
    11. sandbergja will write tutorial: "Do a database call (Galen’s cat counter)"#info sandbergja will write tutorial: "Do a database call (Galen’s cat counter)" (Bmagic, 15:04:42)
    12. sandbergja will go over the Nightwatch test reorg with folks at the Monday at 2pm ET meeting or another time as available (Bmagic, 15:04:51)
    13. ACTION: sandbergja will write tutorial: "Do a database call (Galen’s cat counter)" (Bmagic, 15:05:50)

  3. Evergreen release (Bmagic, 15:07:50)
    1. https://wiki.evergreen-ils.org/doku.php?id=newdevs:meetings:agenda-2023-11 (terranm, 15:08:19)
    2. https://wiki.evergreen-ils.org/doku.php?id=dev:bug_squashing:2023-11 (Bmagic, 15:08:54)
    3. : New Devs Release Building Party tomorrow here --> https://wiki.evergreen-ils.org/doku.php?id=newdevs:meetings:agenda-2023-11 (abneiman, 15:11:59)

  4. Documentation (Bmagic, 15:14:33)
    1. zero uncommitted docs PRa (Bmagic, 15:17:11)

  5. Launchpad Status (as of noon Eastern) (Bmagic, 15:17:20)
    1. Open Bugs - 3138 (Bmagic, 15:17:38)
    2. Pullrequests - 85 (Bmagic, 15:17:39)
    3. Signedoff - 4 (Bmagic, 15:17:39)

  6. Launchpad Status since last meeting#topic Launchpad Status since last meeting (Bmagic, 15:17:49)
  7. Launchpad Status since last meeting (Bmagic, 15:18:05)
    1. Bugs Added - 88 (Bmagic, 15:18:13)
    2. Pullrequest tag Added - 19 (Bmagic, 15:18:14)
    3. Signedoff tag Added - 8 (Bmagic, 15:18:14)
    4. Fix Committed - 12 (Bmagic, 15:18:14)

  8. New Business - Getting `ng lint` rolling again (bug 1850473) - Jane (Bmagic, 15:22:08)
    1. https://bugs.launchpad.net/evergreen/+bug/1850473 (Bmagic, 15:22:21)

  9. New Business - Test failures, including at least one critical regression (bug 2043437) - Jane (Bmagic, 15:33:56)
    1. https://bugs.launchpad.net/evergreen/+bug/2043437 (Bmagic, 15:34:00)

  10. New Business - How can we get computers running our tests regularly again? - Jane (Bmagic, 15:47:06)
    1. for anybody wanting to run the tests, or try it out: https://wiki.evergreen-ils.org/doku.php?id=dev:contributing:qa#types_of_tests (sandbergja, 15:47:14)
    2. ACTION: sandbergja will investigate getting more tests into gh actions (Bmagic, 15:53:48)

  11. Keep an eye out for Angular 17 / Bootstrap 5.3 upgrade blockers and note them on bug 2043490 - Stephanie (Bmagic, 15:54:14)
    1. https://bugs.launchpad.net/evergreen/+bug/2043490 (Bmagic, 15:54:19)

  12. Other (eeevil) (Bmagic, 15:55:28)
    1. I've requested we keep XMPP as the default OpenSRF transport in EG main for the time being. There's no redis release of OpenSRF yet, so support is only in a side branch, and having redis be the default will make dev (especially backport-focused dev, like bug fixes) more painful because you can't just switch branches and test the code. Also, I'm not convinced that it's deeply understood by more folks than berick, and that puts a lot of pressure (eeevil, 15:55:45)

  13. Announcements (Bmagic, 16:03:05)
    1. Next Meeting is Tuesday, December 12th (Bmagic, 16:03:13)


Meeting ended at 16:03:20 US/Eastern (full logs).

Action items

  1. jeff will make tutorial: "Add missing field to print template"
  2. jeff will write tutorial "Retrieve a user's setting and do something based on its value"#action jeff will write tutorial "Retrieve a user's setting and do something based on its value"
  3. mmorgan will explore moving LP stats to community site and automating same
  4. sandbergja will write tutorial: "Do a database call (Galen’s cat counter)"
  5. sandbergja will investigate getting more tests into gh actions


Action items, by person

  1. jeff
    1. jeff will make tutorial: "Add missing field to print template"
    2. jeff will write tutorial "Retrieve a user's setting and do something based on its value"#action jeff will write tutorial "Retrieve a user's setting and do something based on its value"
  2. mmorgan
    1. mmorgan will explore moving LP stats to community site and automating same
  3. sandbergja
    1. sandbergja will write tutorial: "Do a database call (Galen’s cat counter)"
    2. sandbergja will investigate getting more tests into gh actions


People present (lines said)

  1. Bmagic (107)
  2. sandbergja (45)
  3. abneiman (24)
  4. eeevil (17)
  5. sleary (14)
  6. terranm (14)
  7. JBoyer (11)
  8. Dyrcona (10)
  9. mmorgan (8)
  10. csharp_ (7)
  11. pinesol (6)
  12. shulabear (6)
  13. jeff (5)
  14. phasefx (3)
  15. smayo (2)
  16. kmlussier (1)
  17. Stompro (1)
  18. collum (1)


Generated by MeetBot 0.1.4.