#evergreen: 2024-02-13 - Developer Meeting

Meeting started by Bmagic at 15:06:29 US/Eastern (full logs).

Meeting summary

    1. Agenda at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2024-02-13 (Bmagic, 15:06:35)

  1. Introductions (Bmagic, 15:07:02)
    1. Bmagic = Blake GH, MOBIUS (Bmagic, 15:07:07)
    2. Stompro = Josh Stompro, LARL (Stompro, 15:07:22)
    3. gmcharlton = Galen Charlton, Equinox (gmcharlton, 15:07:22)
    4. terranm57 = Terran McCanna, PINES (terranm57, 15:07:28)
    5. shulabear = Shula Link, GCHRL (shulabear, 15:07:29)
    6. collum = Garry Collum, KCPL (collum, 15:07:29)
    7. csharp_ = the actual and only Chris Sharp (csharp_, 15:07:31)
    8. dluch = Debbie Luchenbill, MOBIUS (dluch, 15:07:41)
    9. mmorgan = Michele Morgan, NOBLE (mmorgan, 15:07:41)
    10. abneiman = Andrea Buntz Neiman, Equinox (abneiman, 15:07:52)
    11. berick Bill Erickson, KCLS (berick, 15:07:56)

  2. Action Items from Last Meeting (Bmagic, 15:08:04)
    1. mmorgan will explore moving LP stats to community site and automating same (Bmagic, 15:08:09)
    2. ACTION: mmorgan will explore moving LP stats to community site and automating same (Bmagic, 15:08:59)
    3. sandbergja will see if gh actions can run the pgtap tests (Bmagic, 15:09:05)
    4. Dyrcona = Jason Stephenson, CW MARS (Dyrcona, 15:09:43)
    5. GalenCharlton will open LP bug with the official proposal for git commit message release-note (Bmagic, 15:09:46)
    6. ACTION: sandbergja will see if gh actions can run the pgtap tests (Bmagic, 15:09:55)
    7. GalenCharlton update the release note script to look for the release-note tags (Bmagic, 15:13:45)
    8. ACTION: gmcharlton - create a Git commit message type and update bug 2051946 (Bmagic, 15:16:35)
    9. https://wiki.evergreen-ils.org/doku.php?id=dev:git#commit_messages (Bmagic, 15:17:26)
    10. ACTION: Stompro will formalize the tense usage in the release-note message (Bmagic, 15:25:47)

  3. Launchpad Status (as of noon Eastern) (Bmagic, 15:28:50)
    1. Open Bugs - 3091 (Bmagic, 15:29:18)
    2. Pullrequests - 107 (Bmagic, 15:29:19)
    3. Signedoff - 8 (Bmagic, 15:29:19)

  4. Launchpad Status since last meeting (Bmagic, 15:29:30)
    1. Bugs Added - 62 (Bmagic, 15:29:34)
    2. Pullrequest tag Added - 39 (Bmagic, 15:29:34)
    3. Signedoff tag Added - 13 (Bmagic, 15:29:34)
    4. Fix Committed - 23 (Bmagic, 15:29:34)

  5. New Business - New Launchpad tag: "caching" (Bmagic, 15:29:52)
    1. ACTION: terranm will make LP tag "caching" official (Bmagic, 15:36:23)

  6. New Business - 3.next / 4.0 release team & schedule? (Bmagic, 15:40:26)
    1. https://wiki.evergreen-ils.org/doku.php?id=dev:evergreen:release_checklist (Bmagic, 15:43:22)
    2. https://bugs.launchpad.net/evergreen/+bug/1993823 (abneiman, 15:55:33)
    3. https://bugs.launchpad.net/evergreen/+bug/2006970 (abneiman, 15:55:33)
    4. https://bugs.launchpad.net/evergreen/+bug/2039609 (abneiman, 15:55:34)
    5. https://bugs.launchpad.net/evergreen/+bug/2006969 (abneiman, 15:55:34)
    6. https://wiki.evergreen-ils.org/doku.php?id=newdevs:meetings:agenda-2023-11 (Bmagic, 15:57:51)

  7. New Business - Next Bug Squashing Week? (Bmagic, 15:59:27)


Meeting ended at 16:02:11 US/Eastern (full logs).

Action items

  1. mmorgan will explore moving LP stats to community site and automating same
  2. sandbergja will see if gh actions can run the pgtap tests
  3. gmcharlton - create a Git commit message type and update bug 2051946
  4. Stompro will formalize the tense usage in the release-note message
  5. terranm will make LP tag "caching" official


Action items, by person

  1. gmcharlton
    1. gmcharlton - create a Git commit message type and update bug 2051946
  2. mmorgan
    1. mmorgan will explore moving LP stats to community site and automating same
  3. Stompro
    1. Stompro will formalize the tense usage in the release-note message
  4. UNASSIGNED
    1. sandbergja will see if gh actions can run the pgtap tests
    2. terranm will make LP tag "caching" official


People present (lines said)

  1. Bmagic (92)
  2. gmcharlton (40)
  3. abneiman (31)
  4. Dyrcona (24)
  5. terranm57 (22)
  6. csharp_ (15)
  7. pinesol (13)
  8. shulabear (8)
  9. berick (7)
  10. sleary (6)
  11. mmorgan (5)
  12. dluch (4)
  13. Stompro (3)
  14. kmlussier (2)
  15. collum (1)


Generated by MeetBot 0.1.4.