#evergreen: 2024-07-09 Developer Meeting
Meeting started by abneiman at 15:00:17 US/Eastern
(full logs).
Meeting summary
- 
  - agenda:
    https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2024-07-09#new_business
    (abneiman,
    15:00:33)
 
 
- Introductions (abneiman, 15:01:01)
  - redavis = Ruth Frasur Davis, ECDI (redavis,
    15:01:24)
 
  - dluch = Debbie Luchenbill, MOBIUS (dluch,
    15:01:30)
 
  - mmorgan = Michele Morgan, NOBLE (mmorgan,
    15:01:35)
 
  - phasefx_ = Jason Etheridge, EOLI (phasefx_,
    15:01:40)
 
  - abneiman = Andrea Buntz Neiman, EOLI
    (abneiman,
    15:01:46)
 
  - smayo = Steven Mayo, PINES (smayo,
    15:01:47)
 
  - sandbergja = Jane Sandberg, PUL (sandbergja,
    15:01:49)
 
  - terranm = Terran McCanna, PINES (terranm,
    15:01:55)
 
  - berick Bill Erickson, KCLS (berick,
    15:02:21)
 
 
- Action Items from Last Meeting (abneiman, 15:03:00)
  - gmcharlt - create a Git commit message type and
    update bug 2051946 (abneiman,
    15:03:11)
 
  - eeevil = Mike Rylander, EOLI (eeevil,
    15:03:31)
 
  - Dyrcona = Jason Stephenson, CWMARS (Dyrcona,
    15:03:37)
 
  - mmorgan will explore moving LP stats to
    community site and automating same (abneiman,
    15:04:14)
 
  - JBoyer = Jason Boyer, EOLI (JBoyer,
    15:04:32)
 
  - collum = Garry Collum, kcpl (collum,
    15:04:50)
 
  - ACTION: mmorgan will
    open a ticket for  moving LP stats to community site &
    automating same (abneiman,
    15:05:20)
 
  - eeevil will open a bug for cross-column stats
    targets (abneiman,
    15:05:42)
 
  - shulabear = Shula Link, GCHRL (shulabear,
    15:06:11)
 
  - ACTION: eeevil will
    open a bug for cross-column stats targets (abneiman,
    15:06:38)
 
  - ACTION: gmcharlt -
    create a Git commit message type and update bug 2051946 (abneiman,
    15:06:48)
 
  - Dyrcona will take a look at bug 1017990
    (abneiman,
    15:07:08)
 
  - kmlussier will update wiki (commit message
    standards) to include details about shared components/pullrequest
    rule for LP tagging on multi-commits (abneiman,
    15:08:26)
 
  - kmlussier has done this:
    https://wiki.evergreen-ils.org/doku.php?id=dev:git&do=diff&rev2%5B0%5D=1712683062&rev2%5B1%5D=1720473693&difftype=sidebyside
    (abneiman,
    15:08:40)
 
  - redavis, Dyrcona, abneiman, LindaJansova, EvaCe
    will investigate and see what it will take to move our translations
    to POEditor (abneiman,
    15:09:32)
 
  - scottangel = Scott Angel, MOBIUS (scottangel,
    15:11:33)
 
  - quoting redavis: We did walk through POEditor
    plans and Galen was able to get some new functionality added.
    Because of the Project's non-profit status, it didn't cost anything.
    But now, we're looking at what it'll take to make decisions and port
    stuff (if deemed useful) from Launchpad to POEditor. (abneiman,
    15:12:27)
 
  - redavis will look at making a regular calendar
    event for translation work in lock step with point releases
    (abneiman,
    15:13:01)
 
  - ACTION: redavis will
    look at making a regular calendar event for translation work in lock
    step with point releases (abneiman,
    15:16:05)
 
  - ACTION: : Dyrcona
    will look into git integration with POEditor (abneiman,
    15:18:19)
 
  - redavis clarifies that POEditor offers no
    subscription fee to open source projects - not non-profit.
    (abneiman,
    15:19:27)
 
 
- Release info (abneiman, 15:19:56)
  - two OpenSRF releases!
    https://evergreen-ils.org/evergreen-and-opensrf-security-releases-evergreen-3-10-5-3-11-6-3-12-4-3-13-1-opensrf-3-2-5-and-3-3-1/
    (abneiman,
    15:20:16)
 
  - also, Evergreen security releases!
    https://evergreen-ils.org/evergreen-and-opensrf-security-releases-evergreen-3-10-5-3-11-6-3-12-4-3-13-1-opensrf-3-2-5-and-3-3-1/
    (abneiman,
    15:20:38)
 
  - 3.14 Roadmap is here:
    https://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap -
    mark your calendars! (abneiman,
    15:21:39)
 
  - given that we just did a security release, is
    there any intent to do a further July point release (for
    non-security bugfixes) or are we waiting til August? (abneiman,
    15:22:53)
 
  - yes, Virginia, there will be a July point
    release (abneiman,
    15:25:15)
 
  - ACTION: sandbergja,
    abneiman, redavis, and mmorgan will put out said point
    release (abneiman,
    15:25:38)
 
 
- Launchpad stats (abneiman, 15:26:09)
 
- New Business (abneiman, 15:27:49)
  - Can we make some progress on some of these
    issues?
    http://irc.evergreen-ils.org/evergreen/2024-03-12#i_547284
    (abneiman,
    15:28:14)
 
  - agreed upon the following: 1) sandbergja will
    create a needstestplan tag, which will be appplied to PR'd bugs if a
    test plan is lacking and needed; 2) we prefer if all PR'd bugs
    ALREADY have a test plan from the patch author, but if not, anyone
    can provide them; 3) mmorgan will update the LP stats monthly pull
    to include new uses of needswork, needsrebase, and
    needstestplan (abneiman,
    15:49:08)
 
  - several items on the 3.14 roadmap are already
    pullrequested, and two are signed off - can these get some eyes to
    avoid last minute merge scrambling? (abneiman,
    15:50:57)
 
  - ACTION: abneiman will
    review existing EOLI PRs for test plans (abneiman,
    15:52:35)
 
  - ACTION: discussion
    item for next meeting: test plans for big features (abneiman,
    16:03:36)
 
  - AGREED: we're all
    gonna stay hydrated (abneiman,
    16:04:47)
 
 
Meeting ended at 16:05:22 US/Eastern
(full logs).
Action items
  - mmorgan will open a ticket for  moving LP stats to community site & automating same
 
  - eeevil will open a bug for cross-column stats targets
 
  - gmcharlt - create a Git commit message type and update bug 2051946
 
  - redavis will look at making a regular calendar event for translation work in lock step with point releases
 
  - : Dyrcona will look into git integration with POEditor
 
  - sandbergja, abneiman, redavis, and mmorgan will put out said point release
 
  - abneiman will review existing EOLI PRs for test plans
 
  - discussion item for next meeting: test plans for big features
 
Action items, by person
  -  abneiman 
    - sandbergja, abneiman, redavis, and mmorgan will put out said point release
 
    - abneiman will review existing EOLI PRs for test plans
 
  
 
  -  Dyrcona 
    - : Dyrcona will look into git integration with POEditor
 
  
 
  -  eeevil 
    - eeevil will open a bug for cross-column stats targets
 
  
 
  -  mmorgan 
    - mmorgan will open a ticket for  moving LP stats to community site & automating same
 
    - sandbergja, abneiman, redavis, and mmorgan will put out said point release
 
  
 
  -  redavis 
    - redavis will look at making a regular calendar event for translation work in lock step with point releases
 
    - sandbergja, abneiman, redavis, and mmorgan will put out said point release
 
  
 
  -  sandbergja 
    - sandbergja, abneiman, redavis, and mmorgan will put out said point release
 
  
 
  - UNASSIGNED
    - gmcharlt - create a Git commit message type and update bug 2051946
 
    - discussion item for next meeting: test plans for big features
 
  
 
People present (lines said)
  - abneiman (141)
 
  - redavis (47)
 
  - Dyrcona (22)
 
  - mmorgan (19)
 
  - sandbergja (19)
 
  - sleary (16)
 
  - pinesol (13)
 
  - dluch (12)
 
  - jeffdavis (8)
 
  - shulabear (7)
 
  - terranm (7)
 
  - eeevil (6)
 
  - smayo (3)
 
  - phasefx_ (3)
 
  - JBoyer (2)
 
  - berick (2)
 
  - scottangel (1)
 
  - collum (1)
 
Generated by MeetBot 0.1.4.