#evergreen: 2024-09-10 - Developer Meeting

Meeting started by Bmagic at 15:00:18 US/Eastern (full logs).

Meeting summary

    1. Agenda at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2024-09-10 (Bmagic, 15:00:24)

  1. Introductions (Bmagic, 15:00:28)
    1. Bmagic = Blake GH, MOBIUS (Bmagic, 15:00:32)
    2. Dyrcona = Jason Stephenson, C/W MARS, Inc. (Dyrcona, 15:00:42)
    3. eeevil = Mike Rylander, EOLI (eeevil, 15:00:45)
    4. csharp_ = Chris Sharp, GPLS (csharp_, 15:00:47)
    5. collum = Garry Collum, KCPL (collum, 15:00:49)
    6. shulabramble = Shula Link, GCHRL (shulabramble, 15:00:51)
    7. dluch = Debbie Luchenbill, MOBIUS (dluch, 15:00:56)
    8. berick Bill Erickson, KCLS (berick, 15:01:32)
    9. abneiman = Andrea Buntz Neiman, EOLI (abneiman, 15:01:44)
    10. mmorgan = Michele Morgan, NOBLE (mmorgan, 15:02:08)
    11. sandbergja = Jane Sandberg, PUL (sandbergja, 15:02:11)
    12. sleary = Stephanie Leary, EOLI (sleary, 15:02:28)
    13. jeff = Jeff Godin, Traverse Area District Library (TADL) (jeff, 15:02:35)

  2. Action Items from Last Meeting (Bmagic, 15:02:50)
    1. eeevil will open a bug for cross-column stats targets (Bmagic, 15:02:55)
    2. ACTION: eeevil will open a bug for cross-column stats targets (Bmagic, 15:03:34)
    3. gmcharlt - create a Git commit message type and update bug 2051946 (Bmagic, 15:03:59)
    4. terranm = Terran McCanna, PINES (terranm, 15:04:24)
    5. ACTION: gmcharlt - create a Git commit message type and update bug 2051946 (Bmagic, 15:05:02)
    6. redavis = Ruth Frasur Davis, ECDI (redavis, 15:05:55)
    7. redavis will look at making a regular calendar event for translation work in lock step with point releases (Bmagic, 15:05:56)
    8. jvwoolf is Jessica Woolford, Bibliomation (jvwoolf, 15:10:25)
    9. ACTION: abneiman will intentionally solicit feedback from translators about translation work in lock step with point releases (Bmagic, 15:17:08)
    10. Dyrcona will look into git integration with POEditor (Bmagic, 15:17:49)
    11. ACTION: waiting on (Bmagic, 15:20:08)
    12. ACTION: waiting on gmcharlt for access to POEditor for git integration (Bmagic, 15:20:36)
    13. sleary and sandbergja will create/consolidate the test writing wiki page(s) (Bmagic, 15:20:51)
    14. ACTION: sleary and sandbergja will create/consolidate the test writing wiki page(s) (Bmagic, 15:21:13)
    15. sandbergja will make it easier for folks to know how to run the tests in single file mode and all-mode (Bmagic, 15:21:19)
    16. berick and jeff will look at making Hatch look better in the chrome store, so that it's not removed (Bmagic, 15:21:38)
    17. berick: added pullrequest for bug 2076921 (Bmagic, 15:21:43)
    18. ACTION: bug 2076921 expected to get more testing and merged, and beta uploaded to store (Bmagic, 15:26:02)
    19. Bmagic will work on upgrading the version of DokuWiki (Bmagic, 15:26:11)

  3. Evergreen (Bmagic, 15:27:39)
    1. Point releases 9/18 - signups here BuildMaster Coordination (Bmagic, 15:27:44)
    2. https://docs.google.com/spreadsheets/d/1gZayHfF7qK0zwLMEAXt-PbKBMiAM_F6EZguqzIYceBY/edit?usp=sharing (Bmagic, 15:27:48)

  4. Documentation (Bmagic, 15:30:37)
    1. Documentation Interest Group (DIG) met on Sept. 5 (Bmagic, 15:30:46)
    2. Defined many terms to run through Vale (https://vale.sh/) for documentation consistency checks (Bmagic, 15:30:51)
    3. Discussed last Vale spreadsheet and getting as many of those fixed by October's meeting as possible (Bmagic, 15:30:56)
    4. October's meeting with focus on 3.14 documentation needs (Bmagic, 15:31:02)
    5. Question (went to listserv, too): This bug: https://docs.evergreen-ils.org/docs/latest/opac/visibility_on_the_web.html is orphaned in the docs. Is it still a valid page? Is the part about SKOS Support that says “This is an experimental, "under-the-hood" feature that will be built upon in subsequent releases.” correct? Is it still an experimental feature? (Bmagic, 15:31:09)
    6. https://vale.sh/ (Bmagic, 15:31:38)
    7. https://docs.evergreen-ils.org/docs/latest/opac/visibility_on_the_web.html (Bmagic, 15:31:40)
    8. https://stuff.coffeecode.net/2017/evergreen-progressive-web-app/#/ (Bmagic, 15:33:11)
    9. Next DIG meeting is October 3. (Bmagic, 15:38:05)

  5. Launchpad Status (as of noon Eastern) (Bmagic, 15:40:45)
    1. Open Bugs - 3141 (Bmagic, 15:40:55)
    2. Pullrequests - 71 (Bmagic, 15:40:55)
    3. Signedoff - 24 (Bmagic, 15:40:55)
    4. Needswork - 87 (Bmagic, 15:40:55)
    5. Needstestplan - 3 (Bmagic, 15:40:55)
    6. Needsrebase - 26 (Bmagic, 15:40:56)

  6. Launchpad Status since last meeting (Bmagic, 15:41:00)
    1. Bugs Added - 61 (Bmagic, 15:41:04)
    2. Pullrequest tag Added - 40 (Bmagic, 15:41:04)
    3. Signedoff tag Added - 10 (Bmagic, 15:41:05)
    4. Needswork tag Added - 13 (Bmagic, 15:41:07)
    5. Needstestplan tag Added - 3 (Bmagic, 15:41:09)
    6. Needsrebase tag Added - 6 (Bmagic, 15:41:11)
    7. Fix Committed - 40 (Bmagic, 15:41:15)

  7. New Business - Preparing for OPAC template upgrade to Bootstrap 5: rewrite jQuery-specific JS wherever possible, please. - SL (Bmagic, 15:41:18)
    1. https://wiki.evergreen-ils.org/doku.php?id=opac:bootstrap5 (Bmagic, 15:48:26)

  8. redis (Bmagic, 15:53:47)
  9. passing the dev-meet-runner-torch (Bmagic, 15:57:58)
  10. Announcements (Bmagic, 16:01:09)
    1. Next Meeting is October 8, 2024 (Bmagic, 16:01:13)
    2. Hack-A-Way, November 12-14 in Boston, MA (Bmagic, 16:01:17)


Meeting ended at 16:01:24 US/Eastern (full logs).

Action items

  1. eeevil will open a bug for cross-column stats targets
  2. gmcharlt - create a Git commit message type and update bug 2051946
  3. abneiman will intentionally solicit feedback from translators about translation work in lock step with point releases
  4. waiting on
  5. waiting on gmcharlt for access to POEditor for git integration
  6. sleary and sandbergja will create/consolidate the test writing wiki page(s)
  7. bug 2076921 expected to get more testing and merged, and beta uploaded to store


Action items, by person

  1. abneiman
    1. abneiman will intentionally solicit feedback from translators about translation work in lock step with point releases
  2. eeevil
    1. eeevil will open a bug for cross-column stats targets
  3. sandbergja
    1. sleary and sandbergja will create/consolidate the test writing wiki page(s)
  4. sleary
    1. sleary and sandbergja will create/consolidate the test writing wiki page(s)
  5. UNASSIGNED
    1. gmcharlt - create a Git commit message type and update bug 2051946
    2. waiting on
    3. waiting on gmcharlt for access to POEditor for git integration
    4. bug 2076921 expected to get more testing and merged, and beta uploaded to store


People present (lines said)

  1. Bmagic (122)
  2. sleary (32)
  3. redavis (24)
  4. dluch (22)
  5. sandbergja (12)
  6. abneiman (11)
  7. jeff (11)
  8. pinesol (10)
  9. berick (9)
  10. shulabramble (8)
  11. Dyrcona (8)
  12. csharp_ (7)
  13. mmorgan (5)
  14. jeffdavis (5)
  15. jvwoolf (4)
  16. eeevil (2)
  17. collum (1)
  18. terranm (1)


Generated by MeetBot 0.1.4.