#evergreen: 2024-10-08 - Developer Meeting

Meeting started by Bmagic at 15:00:16 US/Eastern (full logs).

Meeting summary

    1. Agenda at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2024-10-08 (Bmagic, 15:00:23)

  1. Introductions (Bmagic, 15:00:28)
    1. Bmagic = Blake GH, MOBIUS (Bmagic, 15:00:32)
    2. terranm = Terran McCanna, PINES (terranm, 15:00:42)
    3. csharp = Chris Sharp, GPLS (csharp_, 15:00:44)
    4. redavis = Ruth Frasur Davis, ECDI (redavis, 15:00:45)
    5. jeff = Jeff Godin, Traverse Area District Library (TADL) (jeff, 15:00:46)
    6. collum = Garry Collum, KCPL (collum, 15:00:49)
    7. Dyrcona = Jason Stephenson, CW MARS (Dyrcona, 15:00:51)
    8. phasefx = Jason Etheridge, EOLI (phasefx, 15:00:52)
    9. mmorgan = Michele Morgan, NOBLE (mmorgan, 15:00:58)
    10. berick Bill Erickson, KCLS (berick, 15:00:58)
    11. sleary = Stephanie Leary, EOLI (sleary, 15:00:59)
    12. eeevil = Mike Rylander, EOLI (eeevil, 15:01:06)
    13. smayo = Steven Mayo, PINES (smayo, 15:01:55)
    14. scottangel = Scott Angel, MOBIUS (scottangel, 15:02:00)
    15. shulabramble = Shula Link, GCHRL (shulabramble, 15:02:11)
    16. abneiman = Andrea Buntz Neiman, EOLI (abneiman, 15:02:26)
    17. Brian, Sitka (briank, 15:03:06)

  2. Actions (shulabramble, 15:06:52)
    1. eeevil will open a bug for cross-column stats targets (shulabramble, 15:07:30)
    2. ACTION: eeevil will open a bug for cross-column stats targets (shulabramble, 15:09:03)
    3. gmcharlt - create a Git commit message type and update bug 2051946 (shulabramble, 15:12:01)
    4. ACTION: gmcharlt - create a Git commit message type and update bug 2051946 (shulabramble, 15:13:28)
    5. will intentionally solicit feedback from translators about translation work in lock step with point releases; feedback solicited 10/07/2024 (shulabramble, 15:14:03)
    6. will intentionally solicit feedback from translators about translation work in lock step with point releases; feedback solicited 10/07/2024 (shulabramble, 15:14:14)
    7. Linda and Eva gave me some very thoughtful feedback which I'll share below in new business (abneiman, 15:14:38)
    8. waiting on gmcharlt for access to POEditor for git integration (shulabramble, 15:15:29)
    9. ACTION: waiting on gmcharlt for access to POEditor for git integration (shulabramble, 15:15:37)
    10. sleary and sandbergja will create/consolidate the test writing wiki page(s) (shulabramble, 15:15:50)
    11. in progress! We will have more to report next month / at hackaway (sleary, 15:16:08)
    12. ACTION: sleary and sandbergja will report progress on test writing wiki pages next month / at hackaway (shulabramble, 15:17:04)
    13. bug 2076921 expected to get more testing and merged, and beta uploaded to store (shulabramble, 15:17:27)
    14. ACTION: bug 2076921 expected to get more testing and merged, and beta uploaded to store (shulabramble, 15:18:55)

  3. updates (shulabramble, 15:19:10)
    1. OpenSRF (shulabramble, 15:19:30)
    2. Opensrf 3.2.5 and 3.3.2 were released last ... Tuesday? (Dyrcona, 15:20:04)
    3. Evergreen & The Feedback Fest (shulabramble, 15:21:35)
    4. 3.14rc on target for Wednesday Oct 16 (shulabramble, 15:23:39)
    5. https://docs.google.com/spreadsheets/d/1w8GJdVRtC-AO9VwMI9R6TNa4RrFE14_Se43x-RLIjvw/edit?gid=0#gid=0 (redavis, 15:24:44)
    6. https://docs.google.com/spreadsheets/d/1gZayHfF7qK0zwLMEAXt-PbKBMiAM_F6EZguqzIYceBY/edit?gid=0#gid=0 (redavis, 15:40:12)
    7. ACTION: Point releases for 3.12 and 3.13 are targeted for October 16 alongside the release of 3.14 (shulabramble, 15:54:19)
    8. Hatch (shulabramble, 15:54:55)
    9. releases actually on 10/16 :) (abneiman, 15:55:26)
    10. releases actually for realsies on 10/22 (abneiman, 15:56:06)
    11. For realsies Point releases forĀ  3.12 and 3.13 are targeted for October 22 alongside 3.14 (shulabramble, 15:57:00)
    12. Documentation (shulabramble, 15:57:25)
    13. DIG is working on 3.14 docs, if you have docs to share please email evergreen-documentation@list.evergreen-ils.org (abneiman, 15:59:07)

  4. Launchpad Status (as of Noon Eastern) (shulabramble, 16:01:54)
    1. (shulabramble, 16:02:42)
    2. Open Bugs - 3154 (shulabramble, 16:02:47)
    3. Pullrequests - 88 (shulabramble, 16:02:58)
    4. Signedoff - 14 (shulabramble, 16:03:06)
    5. Needwork - 84 (shulabramble, 16:03:16)
    6. Needstestplan - 3 (shulabramble, 16:03:23)
    7. Needsrebase - 27 (shulabramble, 16:03:30)

  5. Launchpad Updates since last meeting (shulabramble, 16:03:49)
    1. Bugs Added - 63 (shulabramble, 16:03:57)
    2. Pullrequest tag Added - 35 (shulabramble, 16:04:08)
    3. Signedoff tag Added - 20 (shulabramble, 16:04:15)
    4. Needswork tag Added - 0 (shulabramble, 16:04:28)
    5. Needstestplan tag Added - 0 (shulabramble, 16:04:37)
    6. Needsrebase tag Added - 3 (shulabramble, 16:04:50)
    7. Fix Committed - 36 (shulabramble, 16:04:59)

  6. New Business (shulabramble, 16:05:21)
    1. kmlussier = Kathy Lussier, NOBLE (kmlussier, 16:05:31)
    2. ACTION: abneiman will take that discussion to the listserv (shulabramble, 16:06:26)
    3. Hackaway local planning requests (shulabramble, 16:06:48)
    4. https://thecastlebeverly.com/ (kmlussier, 16:08:38)
    5. let kmlussier know about The Castle interest (shulabramble, 16:09:50)

  7. Announcements (shulabramble, 16:11:52)
    1. Next Meeting is Tuesday, November 12, 2024 (shulabramble, 16:12:07)


Meeting ended at 16:13:51 US/Eastern (full logs).

Action items

  1. eeevil will open a bug for cross-column stats targets
  2. gmcharlt - create a Git commit message type and update bug 2051946
  3. waiting on gmcharlt for access to POEditor for git integration
  4. sleary and sandbergja will report progress on test writing wiki pages next month / at hackaway
  5. bug 2076921 expected to get more testing and merged, and beta uploaded to store
  6. Point releases for 3.12 and 3.13 are targeted for October 16 alongside the release of 3.14
  7. abneiman will take that discussion to the listserv


Action items, by person

  1. abneiman
    1. abneiman will take that discussion to the listserv
  2. eeevil
    1. eeevil will open a bug for cross-column stats targets
  3. sleary
    1. sleary and sandbergja will report progress on test writing wiki pages next month / at hackaway
  4. UNASSIGNED
    1. gmcharlt - create a Git commit message type and update bug 2051946
    2. waiting on gmcharlt for access to POEditor for git integration
    3. bug 2076921 expected to get more testing and merged, and beta uploaded to store
    4. Point releases for 3.12 and 3.13 are targeted for October 16 alongside the release of 3.14


People present (lines said)

  1. shulabramble (107)
  2. redavis (48)
  3. Dyrcona (34)
  4. Bmagic (32)
  5. abneiman (31)
  6. pinesol (12)
  7. terranm (11)
  8. sleary (10)
  9. csharp_ (10)
  10. kmlussier (9)
  11. mmorgan (7)
  12. eeevil (3)
  13. jeff (2)
  14. scottangel (2)
  15. smayo (1)
  16. berick (1)
  17. phasefx (1)
  18. collum (1)
  19. briank (1)


Generated by MeetBot 0.1.4.