#evergreen: 2024-11-12 - Developer Meeting

Meeting started by shulabramble at 15:00:09 US/Eastern (full logs).

Meeting summary

  1. Introductions (shulabramble, 15:00:43)
    1. abneiman - Andrea Buntz Neiman, Equinox (abneiman, 15:01:04)
    2. Shula Link, GCHRL (shulabramble, 15:01:10)
    3. sandbergja = Jane Sandberg, PUL (sandbergja, 15:01:11)
    4. sleary = Stephanie Leary, Equinox (sleary, 15:01:20)
    5. mmorgan = Michele Morgan, NOBLE (mmorgan, 15:01:25)
    6. JBoyer = Jason Boyer, EOLI (JBoyer, 15:01:42)
    7. Dyrcona = Jason Stephenson, CW MARS (Dyrcona, 15:02:08)
    8. phasefx = Jason Etheridge, EOLI (phasefx, 15:02:12)
    9. jeff = Jeff Godin, Traverse Area District Library (TADL) (jeff, 15:02:17)
    10. collum = Garry Collum, KCPL (collum, 15:02:28)
    11. terranm = Terran McCanna, PINES (terranm, 15:02:33)
    12. eeevil = Mike Rylander, EOLI (eeevil, 15:03:35)
    13. berick Bill Erickson KCLS (berick, 15:03:36)

  2. Actions (shulabramble, 15:03:51)
    1. smayo = Steven Mayo, PINES (smayo, 15:03:51)
    2. csharp, Chris Sharp, GPLS (csharp_, 15:03:53)
    3. Bmagic = Blake GH, MOBIUS (Bmagic, 15:04:00)
    4. rogan, Rogan Hamby EOLI (Rogan, 15:04:05)

  3. eeevil will open a bug for cross-column stats targets (shulabramble, 15:04:15)
    1. dguarrac = Dan Guarracino, OWWL Library System (dguarrac, 15:04:22)
    2. Kathy Lussier, NOBLE (kmlussier, 15:04:34)
    3. scottangel = Scott Angel, MOBIUS (scottangel, 15:05:22)
    4. ACTION: eeevil will open a bug for cross-column stats targets (shulabramble, 15:06:10)

  4. gmcharlt - create a Git commit message type and update bug 2051946 (shulabramble, 15:06:27)
    1. ACTION: gmcharlt - create a Git commit message type and update bug 2051946 (shulabramble, 15:07:45)

  5. waiting on gmcharlt for access to POEditor for git integration (shulabramble, 15:08:13)
    1. ACTION: waiting on gmcharlt for access to POEditor for git integration (shulabramble, 15:09:23)

  6. sleary and sandbergja will report progress on test writing wiki pages next month / at hackaway (shulabramble, 15:09:40)
    1. ACTION: sleary and sandbergja will report progress on test writing wiki pages next month / at hackaway (shulabramble, 15:11:07)

  7. bug 2076921 expected to get more testing and merged, and beta uploaded to store (shulabramble, 15:11:31)
    1. ACTION: berick will work on a rollout plan for hatch update -- bug 2076921 (shulabramble, 15:16:31)

  8. Timing of string freezes w/r/t point releases (shulabramble, 15:16:45)
    1. please see the preceding several lines in the transcript for information on translation timing for point release (abneiman, 15:20:05)
    2. ACTION: sleary will make a new LP tag denoting bugs that involve string changes (shulabramble, 15:24:02)
    3. ACTION: revisit feasibility of automated testing for string changes (shulabramble, 15:35:32)

  9. Updates (shulabramble, 15:36:21)
  10. Launchpad Status (as of noon Eastern) (shulabramble, 15:45:30)
    1. Open Bugs - 3108 (shulabramble, 15:46:25)
    2. Pullrequests - 93 (shulabramble, 15:46:36)
    3. Signedoff - 13 (shulabramble, 15:46:51)
    4. Needswork - 82 (shulabramble, 15:47:01)
    5. Needstestplan - 3 (shulabramble, 15:47:11)
    6. Needsrebase - 24 (shulabramble, 15:47:21)

  11. Launchpad Updates Since Last Meeting (shulabramble, 15:47:33)
    1. Bugs Added - 76 (shulabramble, 15:47:40)
    2. Pullrequest tag Added - 25 (shulabramble, 15:47:47)
    3. Signedoff tag Added - 21 (shulabramble, 15:47:58)
    4. Needswork tag Added - 0 (shulabramble, 15:48:06)
    5. Needstestplan tag added - 0 (shulabramble, 15:48:14)
    6. needsrebase tag added - 0 (shulabramble, 15:48:23)
    7. Fix Committed - 20 (shulabramble, 15:48:31)

  12. New Business (shulabramble, 15:49:04)
  13. Discussion of IRC as home of meetings vs. video or an alternative text platform (abneiman) (shulabramble, 15:49:20)
    1. ACTION: csharp to setup mattermost on EC2 (Dyrcona, 16:06:50)
    2. ACTION: abneiman will poll concerning moving the developer's meeting from IRC to a different platform (shulabramble, 16:11:23)

  14. Okay to merge LP 2055796? berick mentioned "unclear if there's any additional decision processes re: adding github actions" (shulabramble, 16:12:39)
    1. ACTION: it is okay to merge lp2055796, sandberg and berick will attend (shulabramble, 16:19:28)

  15. Announcements (shulabramble, 16:19:52)
    1. Next Dev Meeting on 2024-12-10 (shulabramble, 16:20:36)
    2. "Evergreen Rocks" -- bmagic, 2024-11-12 (shulabramble, 16:21:46)


Meeting ended at 16:22:44 US/Eastern (full logs).

Action items

  1. eeevil will open a bug for cross-column stats targets
  2. gmcharlt - create a Git commit message type and update bug 2051946
  3. waiting on gmcharlt for access to POEditor for git integration
  4. sleary and sandbergja will report progress on test writing wiki pages next month / at hackaway
  5. berick will work on a rollout plan for hatch update -- bug 2076921
  6. sleary will make a new LP tag denoting bugs that involve string changes
  7. revisit feasibility of automated testing for string changes
  8. csharp to setup mattermost on EC2
  9. abneiman will poll concerning moving the developer's meeting from IRC to a different platform
  10. it is okay to merge lp2055796, sandberg and berick will attend


Action items, by person

  1. abneiman
    1. abneiman will poll concerning moving the developer's meeting from IRC to a different platform
  2. berick
    1. berick will work on a rollout plan for hatch update -- bug 2076921
    2. it is okay to merge lp2055796, sandberg and berick will attend
  3. eeevil
    1. eeevil will open a bug for cross-column stats targets
  4. sandbergja
    1. sleary and sandbergja will report progress on test writing wiki pages next month / at hackaway
  5. sleary
    1. sleary and sandbergja will report progress on test writing wiki pages next month / at hackaway
    2. sleary will make a new LP tag denoting bugs that involve string changes
  6. UNASSIGNED
    1. gmcharlt - create a Git commit message type and update bug 2051946
    2. waiting on gmcharlt for access to POEditor for git integration
    3. revisit feasibility of automated testing for string changes
    4. csharp to setup mattermost on EC2


People present (lines said)

  1. shulabramble (106)
  2. abneiman (56)
  3. sandbergja (32)
  4. Bmagic (29)
  5. sleary (19)
  6. berick (18)
  7. pinesol (11)
  8. csharp_ (10)
  9. phasefx (10)
  10. Dyrcona (10)
  11. redavis (9)
  12. eeevil (8)
  13. mmorgan (8)
  14. jeff (6)
  15. smayo (5)
  16. terranm (5)
  17. kmlussier (4)
  18. ianskelskey (4)
  19. collum (2)
  20. tlittle (2)
  21. JBoyer (2)
  22. Rogan (2)
  23. scottangel (2)
  24. dguarrac (1)
  25. jeffdavis (1)
  26. jihpringle (1)
  27. mantis (1)


Generated by MeetBot 0.1.4.