#evergreen: 2025-01-14 - Developer Meeting

Meeting started by shulabramble at 15:00:03 US/Eastern (full logs).

Meeting summary

  1. Introductions (shulabramble, 15:00:18)
    1. shulabramble = Shula Link, GCHRL (shulabramble, 15:00:36)
    2. redavis = Ruth Frasur Davis, ECDI (redavis, 15:00:40)
    3. terranm = Terran McCanna, PINES (terranm, 15:00:43)
    4. collum = Garry Collum, KCPL (collum, 15:01:06)
    5. mmorgan = Michele Morgan, NOBLE (mmorgan, 15:01:10)
    6. phasefx = Jason Etheridge, EOLI :-) (phasefx, 15:01:13)
    7. sleary = Stephanie Leary, EOLI (sleary, 15:01:15)
    8. eeevil = Mike Rylander, EOLI (eeevil, 15:01:31)
    9. Bmagic = Blake GH, MOBIUS (Bmagic, 15:02:01)
    10. berick Bill Erickson, KCLS (berick, 15:02:13)
    11. sandbergja = Jane Sandberg, PUL (sandbergja, 15:02:20)
    12. Dyrcona = Jason Stephenson, C/W MARS (Dyrcona, 15:02:38)
    13. abneiman = Andrea Buntz Neiman, EOLI (abneiman, 15:02:49)

  2. Action Items from Last Meeting (shulabramble, 15:03:38)
  3. eeevil will open a bug for cross-column stats targets (shulabramble, 15:03:51)
    1. jeff = Jeff Godin, Traverse Area District Library (TADL) (jeff, 15:04:26)
    2. ACTION: eeevil will open a bug for cross-column stats targets (shulabramble, 15:04:32)

  4. gmcharlt - create a Git commit message type and update bug 2051946 (shulabramble, 15:04:48)
    1. ACTION: abneiman will reach out to gmcharlt concerning bug 2051946 and POEditor git integration (shulabramble, 15:08:01)
    2. ACTION: sleary and sandbergja will report progress on test writing wiki pages next month (shulabramble, 15:08:22)

  5. sleary will make a new LP tag denoting bugs that involve string changes (shulabramble, 15:09:06)
    1. ACTION: sleary will make a new LP tag denoting bugs that involve string changes (shulabramble, 15:09:30)

  6. sandbergja and sleary will revisit feasibility of automated testing for string changes (shulabramble, 15:09:45)
    1. ACTION: sandbergja and sleary will revisit feasibility of automated testing for string changes (shulabramble, 15:10:12)

  7. abneiman will poll concerning moving the developer's meeting from IRC to a different platform (shulabramble, 15:10:23)
    1. ACTION: abneiman will poll concerning moving the developer's meeting from IRC to a different platform (shulabramble, 15:11:32)

  8. Updates (shulabramble, 15:11:50)
    1. Evergreen - Monthly maintenance releases for 3.13.8 and 3.14.3 are in process right now. They're due out tomorrow, but it will likely be Thursday, January 16 before they're announced. (shulabramble, 15:14:46)
    2. 3.15 has a schedule up and team meetings have commenced! (shulabramble, 15:15:00)
    3. 3.15 -- please populate roadmap if you have features (shulabramble, 15:15:28)
    4. BSW at the end of the month (shulabramble, 15:16:06)
    5. BSW Jan 27-31 (shulabramble, 15:16:19)
    6. Feedback Fest for 3.15 March 31 - April 4 (shulabramble, 15:16:39)

  9. Launchpad Status (as of noon Eastern) (shulabramble, 15:17:41)
  10. Snapshot (shulabramble, 15:17:42)
    1. Open Bugs - 3198 (shulabramble, 15:17:42)
    2. Pullrequests - 99 (shulabramble, 15:17:43)
    3. Signedoff - 5 (shulabramble, 15:17:43)
    4. Needswork - 85 (shulabramble, 15:17:44)
    5. Needstestplan - 2 (shulabramble, 15:17:44)
    6. Needsrebase - 24 (shulabramble, 15:17:45)

  11. Updates Since Last Meeting (shulabramble, 15:17:45)
    1. Bugs Added - 66 (shulabramble, 15:17:46)
    2. Pullrequest tag Added - 18 (shulabramble, 15:17:46)
    3. Signedoff tag Added - 13 (shulabramble, 15:17:47)
    4. Needswork tag Added - 1 (shulabramble, 15:17:47)
    5. Needstestplan tag Added - 0 (shulabramble, 15:17:48)
    6. Needsrebase tag Added - 1 (shulabramble, 15:17:48)
    7. Fix Committed - 20 (shulabramble, 15:17:49)

  12. New Business (shulabramble, 15:18:22)
  13. Evergreen Online Conference 2025 -- Emerging Technologies (shulabramble, 15:22:09)
    1. Call for session proposals is live. Deadline is January 31 -- https://evergreen-ils.org/2025-evergreen-international-online-conference/ (shulabramble, 15:22:40)


Meeting ended at 15:27:07 US/Eastern (full logs).

Action items

  1. eeevil will open a bug for cross-column stats targets
  2. abneiman will reach out to gmcharlt concerning bug 2051946 and POEditor git integration
  3. sleary and sandbergja will report progress on test writing wiki pages next month
  4. sleary will make a new LP tag denoting bugs that involve string changes
  5. sandbergja and sleary will revisit feasibility of automated testing for string changes
  6. abneiman will poll concerning moving the developer's meeting from IRC to a different platform


Action items, by person

  1. abneiman
    1. abneiman will reach out to gmcharlt concerning bug 2051946 and POEditor git integration
    2. abneiman will poll concerning moving the developer's meeting from IRC to a different platform
  2. eeevil
    1. eeevil will open a bug for cross-column stats targets
  3. sandbergja
    1. sleary and sandbergja will report progress on test writing wiki pages next month
    2. sandbergja and sleary will revisit feasibility of automated testing for string changes
  4. sleary
    1. sleary and sandbergja will report progress on test writing wiki pages next month
    2. sleary will make a new LP tag denoting bugs that involve string changes
    3. sandbergja and sleary will revisit feasibility of automated testing for string changes


People present (lines said)

  1. shulabramble (68)
  2. redavis (21)
  3. abneiman (11)
  4. mmorgan (7)
  5. sleary (6)
  6. pinesol (6)
  7. terranm (5)
  8. Dyrcona (4)
  9. sandbergja (3)
  10. collum (3)
  11. jeff (3)
  12. eeevil (3)
  13. berick (2)
  14. phasefx (2)
  15. csharp_ (1)
  16. Bmagic (1)


Generated by MeetBot 0.1.4.