#evergreen: 2025-02-11 - Developer Meeting

Meeting started by shulabramble at 15:00:07 US/Eastern (full logs).

Meeting summary

  1. Introductions (shulabramble, 15:00:16)
    1. Dyrcona = Jason Stephenson, CW MARS (Dyrcona, 15:00:27)
    2. shulabramble = Shula Link, GCHRL (shulabramble, 15:00:32)
    3. redavis = Ruth Frasur, ECDI (redavis, 15:00:35)
    4. berick Bill Erickson, KCLS (berick, 15:00:41)
    5. phasefx = Jason Etheridge, EOLI (phasefx, 15:00:43)
    6. collum = Garry Collum, KCPL (collum, 15:00:49)
    7. sleary = Stephanie Leary, Equinox OLI (sleary, 15:00:49)
    8. mdriscoll = Martha Driscoll, NOBLE (mdriscoll, 15:01:03)
    9. mmorgan = Michele Morgan, NOBLE (mmorgan, 15:01:05)
    10. abneiman = Andrea Buntz Neiman, Equinox OLI (abneiman, 15:01:25)
    11. jeffdavis = Jeff Davis, BC Libraries Cooperative (Sitka) (jeffdavis, 15:02:19)
    12. tslittle = Tiffany Little, PINES (tslittle, 15:02:31)
    13. csharp = Chris Sharp, GPLS (csharp_, 15:02:36)
    14. smayo = Steven Mayo, GPLS (smayo, 15:02:37)

  2. Action Items From January (shulabramble, 15:03:21)
  3. eeevil will open a bug for cross-column stats targets (shulabramble, 15:03:33)
    1. terranm = Terran McCanna, PINES (terranm, 15:05:32)
    2. ACTION: eeevil will open a bug for cross-column stats targets (shulabramble, 15:06:17)

  4. abneiman will reach out to gmcharlt concerning bug 2051946 and POEditor git integration (shulabramble, 15:06:40)
    1. ACTION: awaiting word from gmcharlt concerning bug 2051946 (shulabramble, 15:08:21)
    2. ACTION: gmchartl will reach out about POeditor git stuff prior to the next point release cycle (shulabramble, 15:08:47)
    3. ACTION: sleary and sandbergja will report progress on test writing wiki pages next month (shulabramble, 15:09:04)

  5. sleary will make a new LP tag denoting bugs that involve string changes (shulabramble, 15:10:42)
    1. it hath been created. https://bugs.launchpad.net/evergreen/+bugs?field.tag=i18n-new-strings (shulabramble, 15:12:09)
    2. if your code has been committed and you need it needs translator attention please attach the new tag (shulabramble, 15:13:01)

  6. abneiman will poll concerning moving the developer's meeting from IRC to a different platform (shulabramble, 15:13:50)
    1. ACTION: abneiman will discuss moving the developer's meeting with shulabramble and poll the community (shulabramble, 15:17:08)

  7. Updates (shulabramble, 15:17:25)
  8. Release Info (shulabramble, 15:17:33)
  9. Evergreen (shulabramble, 15:18:13)
    1. Please sign up - https://docs.google.com/spreadsheets/d/1aKffVGU_vIWbtFR_vpoHsqodSw-Kdd5yn65RpfkMKKA/edit?usp=sharing (shulabramble, 15:18:33)

  10. Documentation (shulabramble, 15:20:34)
    1. Documentation Interest Group met on Thursday, Feb. 6 (shulabramble, 15:20:53)
    2. Had a recap from BSW (shulabramble, 15:21:02)
    3. Went over previous months' actions and updates (shulabramble, 15:21:17)
    4. Live demo of using Github for docs submissions (shulabramble, 15:21:27)
    5. Next meeting: Thursday, March 6 (shulabramble, 15:21:40)

  11. Launchpad Status (as of noon Eastern) (shulabramble, 15:23:29)
  12. Snapshot (shulabramble, 15:23:30)
    1. Open Bugs - 3221 (shulabramble, 15:23:30)
    2. Pullrequests - 73 (shulabramble, 15:23:31)
    3. Signedoff - 17 (shulabramble, 15:23:31)
    4. Needswork - 86 (shulabramble, 15:23:32)
    5. Needstestplan - 2 (shulabramble, 15:23:32)
    6. Needsrebase - 25 (shulabramble, 15:23:33)

  13. Updates Since Last Meeting (shulabramble, 15:23:33)
    1. Bugs Added - 69 (shulabramble, 15:23:34)
    2. Pullrequest tag Added - 48 (shulabramble, 15:23:34)
    3. Signedoff tag Added - 61 (shulabramble, 15:23:35)
    4. Needswork tag Added - 9 (shulabramble, 15:23:35)
    5. Needstestplan tag Added - 0 (shulabramble, 15:23:36)
    6. Needsrebase tag Added - 1 (shulabramble, 15:23:36)
    7. Fix Committed - 55 (shulabramble, 15:23:37)

  14. New Business (shulabramble, 15:24:04)
  15. Announcements (shulabramble, 15:25:37)
    1. Next Meeting is 11 March 2025 (shulabramble, 15:25:46)
    2. volunteers needed for translations for point releases and/or 3.15 (shulabramble, 15:29:57)


Meeting ended at 15:32:13 US/Eastern (full logs).

Action items

  1. eeevil will open a bug for cross-column stats targets
  2. awaiting word from gmcharlt concerning bug 2051946
  3. gmchartl will reach out about POeditor git stuff prior to the next point release cycle
  4. sleary and sandbergja will report progress on test writing wiki pages next month
  5. abneiman will discuss moving the developer's meeting with shulabramble and poll the community


Action items, by person

  1. abneiman
    1. abneiman will discuss moving the developer's meeting with shulabramble and poll the community
  2. shulabramble
    1. abneiman will discuss moving the developer's meeting with shulabramble and poll the community
  3. sleary
    1. sleary and sandbergja will report progress on test writing wiki pages next month
  4. UNASSIGNED
    1. eeevil will open a bug for cross-column stats targets
    2. awaiting word from gmcharlt concerning bug 2051946
    3. gmchartl will reach out about POeditor git stuff prior to the next point release cycle


People present (lines said)

  1. shulabramble (74)
  2. redavis (16)
  3. sleary (10)
  4. abneiman (10)
  5. mmorgan (7)
  6. pinesol (6)
  7. terranm (6)
  8. csharp_ (4)
  9. phasefx (2)
  10. smayo (1)
  11. berick (1)
  12. collum (1)
  13. mdriscoll (1)
  14. Dyrcona (1)
  15. tslittle (1)
  16. jeffdavis (1)


Generated by MeetBot 0.1.4.