#evergreen: 2025-03-11 - Developer Meeting

Meeting started by shulabramble at 15:00:07 US/Eastern (full logs).

Meeting summary

  1. Introductions (shulabramble, 15:00:34)
    1. Dyrcona = Jason Stephenson, CWMARS (Dyrcona, 15:00:38)
    2. kmlussier is Kathy Lussier, NOBLE (kmlussier, 15:00:38)
    3. abneiman = Andrea Buntz Neiman, EOLI (abneiman, 15:00:50)
    4. Bmagic = Blake GH, MOBIUS (Bmagic, 15:00:52)
    5. briank = Brian Kennedy, BCLC (briank, 15:00:53)
    6. phasefx = Jason Etheridg, EOLI (phasefx, 15:00:53)
    7. redavis = Ruth Frasur Davis, Evergreen Collaborative Development Initiative (ECDI) (redavis, 15:00:54)
    8. shulabramble = Shula Link, GCHRL (and Clarabelle the Stuffed Bunny joins me today) (shulabramble, 15:01:00)
    9. mmorgan = Michele Morgan, NOBLE (mmorgan1, 15:01:00)
    10. smayo = Steven Mayo, PINES (smayo, 15:01:23)
    11. mdriscoll = Martha Driscoll, NOBLE (mdriscoll, 15:01:43)
    12. sleary = Stephanie Leary, EOLI (sleary, 15:02:47)
    13. terranm = Terran McCanna, PINES (terranm, 15:03:00)
    14. eeevil = Mike Rylander, EOLI (eeevil, 15:03:19)

  2. Action Items from Last Meeting (shulabramble, 15:04:27)
  3. eeevil will open a bug for cross-column stats targets (shulabramble, 15:04:50)
    1. ACTION: eeevil will open a bug for cross-column stats targets (shulabramble, 15:05:57)

  4. awaiting word from gmcharlt concerning bug 2051946 (shulabramble, 15:06:20)
    1. ACTION: Dyrcona will look into bug 2051946 (shulabramble81, 15:10:34)
    2. ACTION: abneiman will follow up with gmcharlt cf. git POeditor integration (shulabramble, 15:18:28)
    3. ACTION: Bmagic will look into transferring POeditor account ownership to a generic EG account (shulabramble, 15:25:10)

  5. sleary and sandbergja will report progress on test writing wiki pages next month (shulabramble, 15:25:33)
    1. ACTION: sleary and sandbergja will report progress on test writing wiki pages next month (shulabramble, 15:26:36)

  6. abneiman will discuss moving the developer's meeting with shulabramble and poll the community (shulabramble, 15:26:56)
    1. ACTION: abneiman will discuss moving the developer's meeting with shulabramble and poll the community (shulabramble, 15:30:35)

  7. Updates (shulabramble, 15:30:47)
  8. Evergreen (shulabramble, 15:33:23)
    1. Feature Slush is 12-03-2025 (shulabramble, 15:33:45)
    2. request from core committers to review / signoff / merge features prior to freeze, currently scheduled for Tuesday March 18 (abneiman, 15:34:37)
    3. Beta 3.15 scheduled for Wednesday 26-03-2025 (shulabramble, 15:34:45)
    4. https://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap:3.15 (abneiman, 15:34:47)
    5. Feedback fest 3/31-4/4 (shulabramble, 15:35:32)

  9. Point Releases (shulabramble, 15:41:12)
    1. https://docs.google.com/spreadsheets/d/1aKffVGU_vIWbtFR_vpoHsqodSw-Kdd5yn65RpfkMKKA/edit?gid=0#gid=0 (redavis, 15:42:06)
    2. sign ups are needed for point releases https://docs.google.com/spreadsheets/d/1aKffVGU_vIWbtFR_vpoHsqodSw-Kdd5yn65RpfkMKKA/edit?gid=0#gid=0 (shulabramble, 15:49:14)
    3. point releases for march postponed until april (shulabramble, 15:50:42)

  10. Documentation (shulabramble, 15:51:20)
    1. DIG met on March 6 (shulabramble, 15:51:58)
    2. Quick meeting, updates on individuals' documentation projects and questions (shulabramble, 15:52:10)
    3. Also got an update on TEP Board's discussion of AI/LLM use with/for documentation. Broader community discussion planned by the Board for Hackfest. (shulabramble, 15:52:19)
    4. Debbie will be working to get previous meeting recordings up on the YouTube site (shulabramble, 15:52:27)
    5. Next meeting, April 3 (shulabramble, 15:52:35)
    6. https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meetings (shulabramble, 15:52:45)
    7. we have an updated VPAT/ACR for 3.14 and it's a vast improvement since 3.11 https://wiki.evergreen-ils.org/doku.php?id=accessibility:vpat (shulabramble, 15:54:06)

  11. Launchpad Status (as of noon Eastern) (shulabramble, 15:55:38)
  12. Snapshot (shulabramble, 15:55:39)
    1. Open Bugs - 3250 (shulabramble, 15:55:39)
    2. Pullrequests - 83 (shulabramble, 15:55:40)
    3. Signedoff - 21 (shulabramble, 15:55:40)
    4. Needswork - 88 (shulabramble, 15:55:41)
    5. Needstestplan - 2 (shulabramble, 15:55:41)
    6. Needsrebase - 26 (shulabramble, 15:55:42)

  13. Updates Since Last Meeting (shulabramble, 15:55:42)
    1. Bugs Added - 77 (shulabramble, 15:55:43)
    2. Pullrequest tag Added - 26 (shulabramble, 15:55:43)
    3. Signedoff tag Added - 15 (shulabramble, 15:55:44)
    4. Needswork tag Added - 4 (shulabramble, 15:55:44)
    5. Needstestplan tag Added - 0 (shulabramble, 15:55:45)
    6. Needsrebase tag Added - 1 (shulabramble, 15:55:45)
    7. Fix Committed - 11 (shulabramble, 15:55:46)

  14. New Business (shulabramble, 15:56:35)
  15. https://bugs.launchpad.net/evergreen/+bug/2073561 Action before next point releases? (shulabramble, 15:56:57)
    1. https://git.evergreen-ils.org/?p=working/Evergreen.git;a=blobdiff;f=Open-ILS/src/sql/Pg/upgrade/1416.data.updated_marc_tag_tables.sql;h=d91c0b6007095d5c7cf54d22052940c8e42a5491;hp=497e2f5a9af547ecec23a40e50664cdaf57c4fd4;hb=41a25170491f727c815ceb7b5bdc283a009d5259;hpb=7b18b3bd51fc72e1b4fba68391085c02d9b92bad (Bmagic, 16:02:55)
    2. https://git.evergreen-ils.org/?p=working/Evergreen.git;a=commit;h=41a25170491f727c815ceb7b5bdc283a009d5259 (Bmagic, 16:04:23)
    3. ACTION: Dyrcona will look at https://bugs.launchpad.net/evergreen/+bug/2073561 (shulabramble, 16:07:23)

  16. Announcements (shulabramble, 16:07:36)
    1. Next Meeting is April 8, 2025 (shulabramble, 16:07:48)


Meeting ended at 16:17:47 US/Eastern (full logs).

Action items

  1. eeevil will open a bug for cross-column stats targets
  2. Dyrcona will look into bug 2051946
  3. abneiman will follow up with gmcharlt cf. git POeditor integration
  4. Bmagic will look into transferring POeditor account ownership to a generic EG account
  5. sleary and sandbergja will report progress on test writing wiki pages next month
  6. abneiman will discuss moving the developer's meeting with shulabramble and poll the community
  7. Dyrcona will look at https://bugs.launchpad.net/evergreen/+bug/2073561


Action items, by person

  1. abneiman
    1. abneiman will follow up with gmcharlt cf. git POeditor integration
    2. abneiman will discuss moving the developer's meeting with shulabramble and poll the community
  2. Bmagic
    1. Bmagic will look into transferring POeditor account ownership to a generic EG account
  3. Dyrcona
    1. Dyrcona will look into bug 2051946
    2. Dyrcona will look at https://bugs.launchpad.net/evergreen/+bug/2073561
  4. eeevil
    1. eeevil will open a bug for cross-column stats targets
  5. shulabramble
    1. abneiman will discuss moving the developer's meeting with shulabramble and poll the community
  6. sleary
    1. sleary and sandbergja will report progress on test writing wiki pages next month


People present (lines said)

  1. shulabramble (101)
  2. redavis (44)
  3. abneiman (34)
  4. Dyrcona (31)
  5. Bmagic (23)
  6. csharp_ (21)
  7. mmorgan (12)
  8. pinesol (11)
  9. sleary (9)
  10. mantis (8)
  11. eeevil (8)
  12. jeffdavis (6)
  13. shulabramble81 (5)
  14. phasefx (3)
  15. kmlussier (2)
  16. mmorgan1 (1)
  17. briank (1)
  18. mdriscoll (1)
  19. terranm (1)
  20. smayo (1)


Generated by MeetBot 0.1.4.