#evergreen: 2025-11-11 Evergreen Development Meeting

Meeting started by gmcharlt at 15:06:40 US/Eastern (full logs).

Meeting summary

    1. Agenda is https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2025-11-11 (gmcharlt, 15:07:06)

  1. Introductions (gmcharlt, 15:07:10)
    1. Dyrcona = Jason Stephenson, CWMARS (Dyrcona, 15:07:31)
    2. gmcharlt = Galen Charlton, Equinox (gmcharlt, 15:07:47)
    3. abneiman = Andrea Buntz Neiman, EOLI (abneiman, 15:07:47)
    4. berick Bill Erickson KCLS (berick, 15:07:49)
    5. collum = Garry Collum, KCPL (collum, 15:08:24)
    6. mmorgan = Michele Morgan, NOBLE (mmorgan, 15:08:25)

  2. Action items from previous meetings (gmcharlt, 15:09:11)
    1. dluch = Debbie Luchenbill, MOBIUS (dluch, 15:09:21)
    2. JBoyer = Jason Boyer, EOLI (JBoyer, 15:09:23)
    3. Bmagic = Blake GH, MOBIUS (Bmagic, 15:09:50)
    4. the RediSRF stream based has received testing during the hack-a-way; various bugfixes under way (gmcharlt, 15:09:55)
    5. Rogan = Rogan Hamby, EOLI (Rogan, 15:10:34)
    6. The Debian 13 compatibility branch has been committed to main (gmcharlt, 15:10:35)
    7. ying_h Ying-Hsiang Huang, KCLS (ying_h, 15:11:24)
    8. 314.1, 3.16.6, and 3.16-bbeta and 3.16-rc released (gmcharlt, 15:12:12)
    9. 3.16.0 will be released tomorrow, 2025-11-12 (gmcharlt, 15:12:22)
    10. DIG had a working meeting on November 6, decided on standard terminology for some common words/phrases in the docs, and updated the style guide. (gmcharlt, 15:13:08)

  3. New business (gmcharlt, 15:13:52)
  4. Proposal for 2026 releases (gmcharlt, 15:14:01)
    1. ACTION: gmcharlt will issue call for 3.17 and 4.0 release teams right after 3.16.0 is relased (gmcharlt, 15:22:27)
    2. smayo = Steven Mayo, GPLS (smayo, 15:28:01)

  5. Translation infrastructure (gmcharlt, 15:28:43)
    1. terranm = Terran McCanna, PINES (terranm, 15:29:23)
    2. ACTION: gmcharlt will raise a call for a working group to recommend translation infrastructure changes (gmcharlt, 15:39:21)

  6. GitHub (gmcharlt, 15:39:38)
    1. ACTION: gmcharlt will initiate thread/call to action on the GitHub transition (gmcharlt, 15:48:58)
    2. ACTION: dluch will propose a session on bug-reporting tools and possible transitions for the 2026 Evergreen Conference (gmcharlt, 15:54:48)

  7. Upcoming releases (gmcharlt, 15:55:16)
    1. Release team needed for November point releases 3.16.1, 3.15.7 & 3.14.12 (?), due Nov 19 - sign up on the Buildmaster Spreadsheet (gmcharlt, 15:55:28)
    2. https://docs.google.com/spreadsheets/d/1aKffVGU_vIWbtFR_vpoHsqodSw-Kdd5yn65RpfkMKKA/edit?usp=sharing (gmcharlt, 15:55:31)

  8. Announcements (gmcharlt, 16:04:31)
    1. Next meeting is 12 December 2025 (gmcharlt, 16:05:01)


Meeting ended at 16:06:22 US/Eastern (full logs).

Action items

  1. gmcharlt will issue call for 3.17 and 4.0 release teams right after 3.16.0 is relased
  2. gmcharlt will raise a call for a working group to recommend translation infrastructure changes
  3. gmcharlt will initiate thread/call to action on the GitHub transition
  4. dluch will propose a session on bug-reporting tools and possible transitions for the 2026 Evergreen Conference


Action items, by person

  1. dluch
    1. dluch will propose a session on bug-reporting tools and possible transitions for the 2026 Evergreen Conference
  2. gmcharlt
    1. gmcharlt will issue call for 3.17 and 4.0 release teams right after 3.16.0 is relased
    2. gmcharlt will raise a call for a working group to recommend translation infrastructure changes
    3. gmcharlt will initiate thread/call to action on the GitHub transition


People present (lines said)

  1. gmcharlt (80)
  2. abneiman (17)
  3. dluch (13)
  4. csharp_ (9)
  5. Bmagic (8)
  6. Rogan (6)
  7. pinesol (5)
  8. berick (4)
  9. JBoyer (4)
  10. Dyrcona (3)
  11. sandbergja (3)
  12. smayo (2)
  13. ying_h (2)
  14. mmorgan (2)
  15. eeevil (2)
  16. goood (1)
  17. collum (1)
  18. terranm (1)


Generated by MeetBot 0.1.4.