#evergreen: 2025-12-09 - Developer's Meeting

Meeting started by shulaprime at 15:00:03 US/Eastern (full logs).

Meeting summary

  1. Intros (shulaprime, 15:00:14)
    1. shulaprime = Shula Link, GCHRL for 22 more days (shulaprime, 15:00:37)
    2. goood = Mike Rylander, EOLI (goood, 15:00:45)
    3. collum = Garry Collum, KCPL (collum, 15:00:52)
    4. jeffdavis = Jeff Davis, BC Libraries Coop (Sitka) (jeffdavis, 15:01:03)
    5. mdriscoll = Martha Driscoll, NOBLE (mdriscoll, 15:01:21)
    6. gmcharlt = Galen Charlton, Equinox (gmcharlt, 15:01:34)
    7. hdarcy = Hannah Darcy, new dev volunteer (hdarcy, 15:01:34)
    8. jeff = Jeff Godin, Traverse Area District Library (TADL) (jeff, 15:02:45)
    9. briank = Brian Kennedy, BC Libraries Coop (Sitka) (briank, 15:03:32)

  2. Action Items from Last Meeting (shulaprime, 15:03:41)
  3. eyes wanted on Redis Stream-based HA/LB branch (https://bugs.launchpad.net/opensrf/+bug/2116980) (shulaprime, 15:03:45)
    1. mmorgan = Michele Morgan, NOBLE (mmorgan, 15:07:33)
    2. ACTION: eyes wanted on Redis Stream-based HA/LB branch (https://bugs.launchpad.net/opensrf/+bug/2116980) (shulaprime, 15:09:42)

  4. csharp_ will look at Debian 13 compatibility (shulaprime, 15:10:23)
    1. abneiman = Andrea Buntz Neiman, EOLI (abneiman, 15:11:26)
    2. ACTION: csharp_ will look at Debian 13 compatibility (shulaprime, 15:11:48)

  5. gmcharlt will issue call for 3.17 and 4.0 release teams right after 3.16.0 is relased (shulaprime, 15:12:07)
    1. ACTION: gmcharlt will issue call for 3.17 and 4.0 release teams in an hour or so (shulaprime, 15:13:32)

  6. gmcharlt will raise a call for a working group to recommend translation infrastructure changes (shulaprime, 15:13:46)
    1. ACTION: gmcharlt will raise a call for a working group to recommend translation infrastructure changes (shulaprime, 15:14:24)

  7. gmcharlt will initiate thread/call to action on the GitHub transition (shulaprime, 15:14:40)
    1. ACTION: gmcharlt will initiate thread/call to action on the GitHub transition (shulaprime, 15:15:41)

  8. dluch will propose a session on bug-reporting tools and possible transitions for the 2026 Evergreen Conference (shulaprime, 15:15:59)
    1. ACTION: dluch will propose a session on bug-reporting tools and possible transitions for the 2026 Evergreen Conference (shulaprime, 15:16:51)

  9. Updates (shulaprime, 15:17:04)
  10. Launchpad Status (as of noon Eastern) (shulaprime, 15:20:39)
  11. Snapshot (shulaprime, 15:20:40)
    1. Open Bugs - 3327 (shulaprime, 15:20:40)
    2. Pullrequests - 118 (shulaprime, 15:20:41)
    3. Signedoff - 17 (shulaprime, 15:20:41)
    4. Needswork - 100 (shulaprime, 15:20:42)
    5. Needstestplan - 2 (shulaprime, 15:20:42)
    6. Needsrebase - 23 (shulaprime, 15:20:43)

  12. Updates Since Last Meeting (shulaprime, 15:20:43)
    1. Bugs Added - 40 (shulaprime, 15:20:44)
    2. Pullrequest tag Added - 21 (shulaprime, 15:20:44)
    3. Signedoff tag Added - 10 (shulaprime, 15:20:45)
    4. Needswork tag Added - 0 (shulaprime, 15:20:45)
    5. Needstestplan tag Added - 0 (shulaprime, 15:20:46)
    6. Needsrebase tag Added - 1 (shulaprime, 15:20:46)
    7. Fix Committed - 29 (shulaprime, 15:20:47)

  13. New Business (shulaprime, 15:21:11)
  14. Release team needed for December point releases 3.16.2, 3.15.8, due Dec. 31 - sign up on the Buildmaster Spreadsheet (shulaprime, 15:21:14)
    1. Buildmaster Spreadsheet link: https://docs.google.com/spreadsheets/d/1aKffVGU_vIWbtFR_vpoHsqodSw-Kdd5yn65RpfkMKKA/edit?usp=sharing (shulaprime, 15:21:38)
    2. abneiman will request volunteers if willing subjects do not step forward (shulaprime, 15:28:30)

  15. Announcements (shulaprime, 15:28:45)
  16. Next Meeting -- 2026-01-13 (shulaprime, 15:29:04)


Meeting ended at 15:30:51 US/Eastern (full logs).

Action items

  1. eyes wanted on Redis Stream-based HA/LB branch (https://bugs.launchpad.net/opensrf/+bug/2116980)
  2. csharp_ will look at Debian 13 compatibility
  3. gmcharlt will issue call for 3.17 and 4.0 release teams in an hour or so
  4. gmcharlt will raise a call for a working group to recommend translation infrastructure changes
  5. gmcharlt will initiate thread/call to action on the GitHub transition
  6. dluch will propose a session on bug-reporting tools and possible transitions for the 2026 Evergreen Conference


Action items, by person

  1. gmcharlt
    1. gmcharlt will issue call for 3.17 and 4.0 release teams in an hour or so
    2. gmcharlt will raise a call for a working group to recommend translation infrastructure changes
    3. gmcharlt will initiate thread/call to action on the GitHub transition
  2. UNASSIGNED
    1. eyes wanted on Redis Stream-based HA/LB branch (https://bugs.launchpad.net/opensrf/+bug/2116980)
    2. csharp_ will look at Debian 13 compatibility
    3. dluch will propose a session on bug-reporting tools and possible transitions for the 2026 Evergreen Conference


People present (lines said)

  1. shulaprime (65)
  2. gmcharlt (9)
  3. abneiman (8)
  4. goood (7)
  5. jeff (6)
  6. pinesol (6)
  7. mmorgan (5)
  8. mdriscoll (2)
  9. hdarcy (1)
  10. phasefx (1)
  11. collum (1)
  12. briank (1)
  13. jeffdavis (1)


Generated by MeetBot 0.1.4.