#evergreen: 2026-01-13 Development Meeting

Meeting started by Dyrcona at 15:01:55 US/Eastern (full logs).

Meeting summary

  1. Introductions (Dyrcona, 15:02:10)
    1. Galen Charlton, Equinox (gmcharlt, 15:02:28)
    2. Dyrcona = Jason Stephenson, CWMARS (Dyrcona, 15:02:29)
    3. jeff = Jeff Godin, Traverse Area District Library (TADL) (jeff, 15:02:30)
    4. phasefx = Jason Etheridge, Equinox (phasefx, 15:02:46)
    5. mmorgan = Michele Morgan, NOBLE (mmorgan, 15:03:12)
    6. mdriscoll = Martha Driscoll, NOBLE (mdriscoll, 15:03:33)
    7. abneiman = Andrea Buntz Neiman, EOLI (abneiman, 15:04:03)
    8. mantis = Gina Monti, Bibliomation (mantis, 15:04:31)

  2. Action Items from Last Meeting (Dyrcona, 15:05:02)
    1. eyes wanted on Redis Stream-based HA/LB branch (Dyrcona, 15:05:32)
    2. Dyrcona (me) has been looking at it without load balancing and it's working so far. (Dyrcona, 15:05:55)
    3. csharp_ will look at Debian 13 compatibility (Dyrcona, 15:07:07)
    4. That's also done and in the main branches for both Evergreen and OpenSRF. (Dyrcona, 15:07:26)
    5. gmcharlt will issue call for 3.17 and 4.0 release teams in an hour or so (Dyrcona, 15:08:07)
    6. gmcharlt will raise a call for a working group to recommend translation infrastructure changes (Dyrcona, 15:09:34)
    7. gmcharlt will initiate thread/call to action on the GitHub transition (Dyrcona, 15:09:41)
    8. dluch will propose a session on bug-reporting tools and possible transitions for the 2026 Evergreen Conference (Dyrcona, 15:10:32)

  3. OpenSRF Release Info (Dyrcona, 15:12:44)
  4. Evergreen Release Info (Dyrcona, 15:14:35)
    1. 3.17 release manager - Galen Charlton (gmcharlt) (Dyrcona, 15:14:52)
    2. Call for 3.17 release team members (Dyrcona, 15:15:15)
    3. Proposed general release date: 29 April 2026 (Dyrcona, 15:15:32)
    4. ACTION: gmcharlt to call for 3.17 release volunteers on the mailing lists (Dyrcona, 15:16:48)
    5. 4.0 release manager - Jason Stephenson (Dyrcona) (Dyrcona, 15:18:01)
    6. https://docs.google.com/spreadsheets/d/1aKffVGU_vIWbtFR_vpoHsqodSw-Kdd5yn65RpfkMKKA/edit?usp=sharing (abneiman, 15:22:17)
    7. Volunteers for the January release requested. (Dyrcona, 15:23:05)
    8. sign up at the usual google sheet: https://docs.google.com/spreadsheets/d/1aKffVGU_vIWbtFR_vpoHsqodSw-Kdd5yn65RpfkMKKA/edit?usp=sharing (Dyrcona, 15:23:40)

  5. Hatch Release Info (Dyrcona, 15:25:55)
  6. Documentation (Dyrcona, 15:27:41)
  7. Launchpad Status (as of noon Eastern) (Dyrcona, 15:30:03)
    1. Snapshot (Dyrcona, 15:30:03)
    2. Open Bugs - 3362 (Dyrcona, 15:30:03)
    3. Pullrequests - 129 (Dyrcona, 15:30:03)
    4. Signedoff - 16 (Dyrcona, 15:30:03)
    5. Needswork - 100 (Dyrcona, 15:30:05)
    6. Needstestplan - 2 (Dyrcona, 15:30:07)
    7. Needsrebase - 21 (Dyrcona, 15:30:09)
    8. Updates Since Last Meeting (Dyrcona, 15:30:11)
    9. Bugs Added - 46 (Dyrcona, 15:30:13)
    10. Pullrequest tag Added - 6 (Dyrcona, 15:30:15)
    11. Signedoff tag Added - 3 (Dyrcona, 15:30:17)
    12. Needswork tag Added - 1 (Dyrcona, 15:30:19)
    13. Needstestplan tag Added - 0 (Dyrcona, 15:30:21)
    14. Needsrebase tag Added - 1 (Dyrcona, 15:30:23)
    15. Fix Committed - 6 (Dyrcona, 15:30:25)

  8. New Business (Dyrcona, 15:31:17)
    1. GitHub Implementation Working Group update (Dyrcona, 15:31:35)
    2. documents of the GitHub WG can be found here: https://drive.google.com/drive/folders/1reBTYZ2JpkRiNTwfaRqhBDdpUlTN8XNE (Dyrcona, 15:34:06)
    3. Translation Tools Working Group update (Dyrcona, 15:36:16)
    4. Documents of the Translation ToolS WG can be found here: https://drive.google.com/drive/folders/1z4v3x4ZNlL9upqpjS3-xPZcC5IPeRnTW (gmcharlt, 15:37:06)

  9. Point Releases next week (Dyrcona, 15:40:10)
  10. Announcements (Dyrcona, 15:41:09)
    1. Next Meeting is 10 February 2026 (Dyrcona, 15:41:24)
    2. Evergreen conference session proposal deadline is today 13 January 2026 (Dyrcona, 15:43:49)
    3. Conference proposal form is at https://docs.google.com/forms/d/e/1FAIpQLSeOxvA0H0couIb61m9JmnqZnJ7dxUgZpw7JlDknjYrnlu6cPg/viewform?usp=sharing&ouid=115637895465765706482 (gmcharlt, 15:44:54)
    4. Super Early Bird Registraiton ends on 15 January 2026 (gmcharlt, 15:45:23)


Meeting ended at 15:48:25 US/Eastern (full logs).

Action items

  1. gmcharlt to call for 3.17 release volunteers on the mailing lists


Action items, by person

  1. gmcharlt
    1. gmcharlt to call for 3.17 release volunteers on the mailing lists


People present (lines said)

  1. Dyrcona (94)
  2. gmcharlt (23)
  3. abneiman (9)
  4. csharp_ (8)
  5. pinesol (6)
  6. mmorgan (3)
  7. jeff (1)
  8. phasefx (1)
  9. mdriscoll (1)
  10. mantis (1)


Generated by MeetBot 0.1.4.