#evergreen: Dev meeting agenda: http://evergreen-ils.org/dokuwiki/doku.php?id=dev:meetings:2011-12-20
Meeting started by bshum at 12:01:43 US/Eastern
(full logs).
Meeting summary
- 
  - http://evergreen-ils.org/dokuwiki/doku.php?id=dev:meetings:2011-12-20
    (bshum,
    12:03:06)
 
 
- Review Past Action Items (bshum, 12:03:36)
  - moodaepo to send out the revised proposed
    time-based release schedule and support cycle for feedback.
    (bshum,
    12:04:07)
- 2. moodaepo to move OpenSRF 1.6 to code museum
    from downloads page (bshum,
    12:06:16)
- 3. bshum to ask DIG about finding a
    representative to join the Release Team (and review related
    processes) (bshum,
    12:08:23)
- ACTION: bshum to
    follow up on that in early 2012, if not sooner. (bshum,
    12:08:34)
- moodaepo has removed OpenSRF 1.6 from the
    downloads page; bshum has added it to the code museum (bshum,
    12:10:21)
- IDEA: Link to
    http://wiki.debian.org/MeetBot from dev:meetings ? (dbs,
    12:10:41)
- moodaepo has sent out a revised release/EOL
    policy discussed during the last developer's meeting and requested
    feedback. (moodaepo,
    12:11:24)
- eeevil added a request for 2.2a2 discussion to
    the agenda (eeevil,
    12:11:44)
 
 
- New Business (bshum, 12:11:58)
  - IDEA: Link to
    http://meetbot.debian.net/Manual.html on dev:meetings for advanced
    use? (moodaepo,
    12:12:32)
- Get release notes into docs/ directory (see
    user/dbs/relnotes_22 in working repo) (dbs,
    12:13:07)
- AGREED:  (eeevil,
    12:14:29)
- ACTION: dbs to open a
    bug that points to user/dbs/relnotes_22 for a merge (dbs,
    12:15:34)
- AGREED: Maintain
    running release notes in docs/RELEASE_NOTES_x_y.txt files in
    source (dbs,
    12:18:06)
- AGREED:  (eeevil,
    12:18:45)
- +1 ;) (berick,
    12:19:34)
- Get “version_upgrade” directory into master: in
    short, one directory that contains the authoritative version of all
    point-to-point upgrades at release boundaries (dbs,
    12:20:05)
- https://bugs.launchpad.net/evergreen/+bug/894052
    contains the arguments I'm making for this approach; not sure if
    there's any concern about it though (dbs,
    12:20:47)
- IDEA: Next meeting, I
    guess we should format things so that the #topic = things to be
    talked about, and #info = things we say about said agenda
    item. (bshum,
    12:21:33)
- AGREED: Next meeting,
    #topics will be #topics and #info will be #info and #ideas will be
    #ideas (dbs,
    12:22:07)
- I like that suggestion about having all
    upgrades in one place. (bshum,
    12:23:22)
- ACTION: dbs to update
    the release process doc with a mention of the version_upgrade
    directory (dbs,
    12:27:39)
- ACTION: eevil to
    merge the branch with the version_upgrade directory (dbs,
    12:28:27)
- AGREED: Henceforth we
    shall maintain release point-to-point database upgrade scripts in
    Open-ILS/src/sql/Pg/version_upgrade in master, and backport where
    applicable (dbs,
    12:29:11)
 
 
- Time to cut another 2.2 alpha? (dbs, 12:30:02)
  - tsbere had offered to cut one before he left
    for lunch ;P (bshum,
    12:30:20)
- tsbere offered to cut the alpha (dbs,
    12:30:22)
- http://goo.gl/3EAzQ shows a
    number of bugs targeted for 2.2.0-alpha2 (dbs,
    12:33:39)
- HELP: dbs is looking
    for some better ways to help others test and sign-off on
    branches (bshum,
    12:45:29)
- AGREED: Noted by
    eeevil: devs agree to push hard on 2.2a2 targeted /bugs/ and get a2
    out asap (bshum,
    12:51:29)
- HELP: If you are
    capable of setting up a clean Evergreen environment on master, have
    the ability to push branches to the working repository, and can
    cherry-pick commits from branches, we need _you_ to help us test and
    sign-off on branches listed at http://goo.gl/3EAzQ (dbs,
    12:57:36)
 
 
- MeetBot is here. (bshum, 12:58:24)
  - ACTION: moodaepo and
    bshum to poke at writing up a wiki page on how to use MeetBot better
    next time. (bshum,
    12:58:44)
 
Meeting ended at 12:58:47 US/Eastern
(full logs).
Action items
  - bshum to follow up on that in early 2012, if not sooner.
- dbs to open a bug that points to user/dbs/relnotes_22 for a merge
- dbs to update the release process doc with a mention of the version_upgrade directory
- eevil to merge the branch with the version_upgrade directory
- moodaepo and bshum to poke at writing up a wiki page on how to use MeetBot better next time.
Action items, by person
  -  bshum 
    - bshum to follow up on that in early 2012, if not sooner.
- moodaepo and bshum to poke at writing up a wiki page on how to use MeetBot better next time.
 
-  dbs 
    - dbs to open a bug that points to user/dbs/relnotes_22 for a merge
- dbs to update the release process doc with a mention of the version_upgrade directory
 
-  moodaepo 
    - moodaepo and bshum to poke at writing up a wiki page on how to use MeetBot better next time.
 
People present (lines said)
  - dbs (67)
- bshum (47)
- eeevil (32)
- moodaepo (15)
- tsbere (8)
- pinesol_green (7)
- berick (7)
- jbondharris (4)
- gmcharlt (1)
- djfiander (1)
Generated by MeetBot 0.1.4.